summaryrefslogtreecommitdiff
path: root/net-misc/yt-dlp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-09 08:15:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-09 08:15:38 +0100
commit21616d4521c47fc859035ab3939842cddd56e374 (patch)
treebbe695483012ac54498cd55c2d9c03c67fef36d0 /net-misc/yt-dlp
parent3fd9d065ab109700e92fc1cea2a6519a39a5b007 (diff)
gentoo auto-resync : 09:08:2022 - 08:15:37
Diffstat (limited to 'net-misc/yt-dlp')
-rw-r--r--net-misc/yt-dlp/Manifest2
-rw-r--r--net-misc/yt-dlp/yt-dlp-2022.8.8.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index 4724f8e85426..874b413454ae 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1,3 +1,5 @@
DIST yt-dlp-2022.7.18.tar.gz 2348854 BLAKE2B 3ef23b1fbc379af2e2a291e96efe495a38d8a7a3db3a45d6131bcaa06cc03843e4c3eee7859c51a7868429ab64759e251a22c5fb320fcbf51d7e2c4ca9ac86d7 SHA512 07552c1b698326152c154ff83fc08b03637234ff448e6b5dd6776c0f37d2a4d892a5c89131c4c9ec8a8c479577018ffbdf7f53538e3dc41497c0fd131c90538a
+DIST yt-dlp-2022.8.8.tar.gz 2361172 BLAKE2B a210786df56faa39a725f2ab06c9cc7805128c2f4fde4c504bd26a09d6a38cf25bea8b52f1471261bb007c8645170a29fae364e3b4008d1ebc8d4f0caf645c35 SHA512 bef1f1110c97f0c8338e94fc2671849cbfe086eb7dba974c623dde2beec29a17dd0c9972603a5af530a07e0721a00e56c6437a2b5d82b39630e3f4f49b51b00b
EBUILD yt-dlp-2022.7.18.ebuild 1824 BLAKE2B a5be6f4534e7476a6a89961e4e38ada99f9ebff77c673332cd1795646a59b3a267d29c514e9aeb4eec3344c8f203859920c19e3dccaa4cf1b7a882d6ded1f823 SHA512 6931b2c14a083ee20476a5ca0abfecf14639d3f1ab628c507352c77ffb255095e7614f0b9010d7a63ac35bbb36d04b5cf3a1a7dde72df586a8ea518a437ecf69
+EBUILD yt-dlp-2022.8.8.ebuild 1829 BLAKE2B 653c11229a14a5f360e24041cee0610d843fd31127712a2460d9d3096a579ad32afb9b09f6eb69fc4695f839c7503bbec0637fb052b2687e86d7439499dfb268 SHA512 be1ee1cc642fa36d49dc26737e8eba82e63c49b01e864c757923ce0021e07dcda1e6823400eecaadf3cfcd3b4b784d64606bbb801acde5e064ef14b32f02cdeb
MISC metadata.xml 505 BLAKE2B 520725078c47caf245904b10aab8929bf9a9a357a70315fda67e7dd59b77cb0c1614e7de03029772288aefa76678c7c4c97c7153364552f5ebe0f951df651e9f SHA512 af72cc5782fe5ed5a6748dcd7ebe7c9393ff7a9ad6d5a1a3a8c2824d323e86f1a97036745570790898fe9a51047601f9a4d95befc0e02b8c16822b7cc94e0734
diff --git a/net-misc/yt-dlp/yt-dlp-2022.8.8.ebuild b/net-misc/yt-dlp/yt-dlp-2022.8.8.ebuild
new file mode 100644
index 000000000000..775abf17078d
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2022.8.8.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit bash-completion-r1 distutils-r1 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # adjust requires for pycryptodome and optional dependencies (bug #828466)
+ sed -ri requirements.txt \
+ -e "s/^(pycryptodome)x/\1/" \
+ -e "/^(brotli.*|certifi|mutagen|websockets)/d" || die
+}
+
+python_test() {
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}