summaryrefslogtreecommitdiff
path: root/net-misc/yt-dlp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-05 23:52:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-05 23:52:45 +0000
commit1c33e521c460dc40899ce7bc919602b842ce27e2 (patch)
tree580eefad4cce1e883e7504b93352a9029b53036d /net-misc/yt-dlp
parent65e4244e411c4f65f55f2aa91f39e228f4c0680b (diff)
gentoo auto-resync : 05:03:2023 - 23:52:45
Diffstat (limited to 'net-misc/yt-dlp')
-rw-r--r--net-misc/yt-dlp/Manifest2
-rw-r--r--net-misc/yt-dlp/yt-dlp-2023.03.04.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index f8ee6fd2c8ac..3519910c2010 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1,4 +1,6 @@
DIST yt-dlp-2023.03.03.tar.gz 5113424 BLAKE2B f20e255e32de15c3d25be2b2d73b526281f84dc2cc92667fa2d8887002559873c74aab98ce6f102705391e6621c8423d0e13f8fe2d01f47cbffa061b2fa74aa2 SHA512 179b96697d44d6bde6ca4f99ef90c70ce4b45d25c919e93355bc479765ee9ccaf37d19768b273b05d8018e1d19cd795acd735de8f62e5f160c446fd0feb4e7de
+DIST yt-dlp-2023.03.04.tar.gz 5125843 BLAKE2B 8c2a610b98e83b6aa4b4daaaaaaf805a2e780a38af21168a90f305196f14716df5830235a600278158a7e3a758e3a5daf56e88cbaa38f4675b52a7bfbfdb1dd2 SHA512 3220ad0d7445351e5786b5ff1634b633a601f64216813129056d0c8470ce8afa2e6df6d402a9381980df6611e9341039cb7f576dfd444b05fbb1417ba1aced52
EBUILD yt-dlp-2023.03.03.ebuild 1910 BLAKE2B fa2ac85fa66dde95dd6805902940cfafcf154c3983f34de502601bf6412068cf039d099a185a6c18ef8957ed3b889b38acecc6b95afa3151fd576bb101bc763b SHA512 779cdaa34655c191515e0e0ec6b5ae6441b87fb6dbc66f6a25b05d9920e54531f6e8dfd1d9272ba014aa613bc8632b88a4f91a42535eecaf9920d53842c4dd09
+EBUILD yt-dlp-2023.03.04.ebuild 1910 BLAKE2B fa2ac85fa66dde95dd6805902940cfafcf154c3983f34de502601bf6412068cf039d099a185a6c18ef8957ed3b889b38acecc6b95afa3151fd576bb101bc763b SHA512 779cdaa34655c191515e0e0ec6b5ae6441b87fb6dbc66f6a25b05d9920e54531f6e8dfd1d9272ba014aa613bc8632b88a4f91a42535eecaf9920d53842c4dd09
EBUILD yt-dlp-9999.ebuild 2032 BLAKE2B f621518216ab8ac6cac20a2083cce0f6f16133507fd09a2384d38504fa8bde43a7dc56903da889a87c477a4991204b266b02f5488ccc325819fde84c4a188ff6 SHA512 c623116051f3c327ebe130807b91aebf0de62f3593f70d41d7e2b7e4f60112223f8951645b860ce7817fe37acd0612c600a1020b1754cf7d15626927f65aa03f
MISC metadata.xml 505 BLAKE2B 520725078c47caf245904b10aab8929bf9a9a357a70315fda67e7dd59b77cb0c1614e7de03029772288aefa76678c7c4c97c7153364552f5ebe0f951df651e9f SHA512 af72cc5782fe5ed5a6748dcd7ebe7c9393ff7a9ad6d5a1a3a8c2824d323e86f1a97036745570790898fe9a51047601f9a4d95befc0e02b8c16822b7cc94e0734
diff --git a/net-misc/yt-dlp/yt-dlp-2023.03.04.ebuild b/net-misc/yt-dlp/yt-dlp-2023.03.04.ebuild
new file mode 100644
index 000000000000..59b22a558dd2
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2023.03.04.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+inherit bash-completion-r1 distutils-r1 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+SRC_URI="https://github.com/yt-dlp/yt-dlp/releases/download/${PV}/${PN}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ~hppa ppc ppc64 ~riscv x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # adjust requires for pycryptodome and optional dependencies (bug #828466)
+ sed -ri requirements.txt \
+ -e "s/^(pycryptodome)x/\1/" \
+ -e "/^(brotli.*|certifi|mutagen|websockets)/d" || die
+}
+
+python_test() {
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}