summaryrefslogtreecommitdiff
path: root/net-misc/yt-dlp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-29 01:25:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-29 01:25:46 +0100
commit04ac238703da84168e02b06fb131d1d17d85be23 (patch)
treef32aa3a6b6a6c879a798006535ad544bf888df73 /net-misc/yt-dlp
parent6405cba4bf18141460bc9fcb8f5580532d4b46f8 (diff)
gentoo auto-resync : 29:09:2024 - 01:25:46
Diffstat (limited to 'net-misc/yt-dlp')
-rw-r--r--net-misc/yt-dlp/Manifest2
-rw-r--r--net-misc/yt-dlp/yt-dlp-2024.09.27.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index 046c22bad93d..ba2d40c9318c 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1,4 +1,6 @@
DIST yt-dlp-2024.08.06.tar.gz 5710396 BLAKE2B ba657ddd054fc814adfc9644378ab51e50f980a8ce9d9589d0e69d4242fc68a22314a230135c54737a1b453d853d811a48d1737b05c2e04d3494ca580a6937b0 SHA512 5db3ceeb217148755e31492d490bfeb69879400873274dec4320ce58b49dce9ce93d1e32714d6b7433364780e269087fc55acb94ef4fca0d998c504f2efac41f
+DIST yt-dlp-2024.09.27.tar.gz 5750902 BLAKE2B 22c36dc45fd8f0b059542edf721757d50f4f4df640dfb2415ef0143e287e7ae6535e868705faa738ad1be3dd07bede85660ecc47f133c2eba2d13abc40e99c71 SHA512 9440eafd8c68bc4cc9d34edf616dbb34e0810556d21bd2276198359e653d155586cc398ebedc1088fb238dae78f62f2443463e4a63f90b323aec4ca53d3211e1
EBUILD yt-dlp-2024.08.06.ebuild 2424 BLAKE2B f603a94c2207389f9541e684df31fedb31c7dca93c7ea02b5e5debe35d17cf4d4ae9c2c274f6a858dece8d9a57ee70b57df4127135ae72abe11968699bbeba7c SHA512 2a4d340022f2120e3de35208b1657ca6484482a6930fc60960d899edf74bfe96b08089fa974968e0ff9f7fa2a0b7c4a93fa8074f44507e5c82d578523f4b4327
+EBUILD yt-dlp-2024.09.27.ebuild 2422 BLAKE2B 50c668d85da9dab582c8ba0a9a52b4bf80efedc4bead010de178d3c8763fcc22a406c538982d3ae2849db8572649a80cac339a4f7f30cbfe40a569b319aa3798 SHA512 bee00fae0f0ac28ee3af28e44caa37f61f6e9386b296d62484d22e4e72b64af4e3517b17bc6990ef76b21fe3ab3cf17862f495a748c215aa844ebb1374321f04
EBUILD yt-dlp-9999.ebuild 2442 BLAKE2B 6923dbb9824c38ce22a3c627cf82ae24c25e0787a74eee4381007c31d9649c058913985a14bd33bce50dbf3f2bdd5f78b6014f81c5e9d4ad5c0ddd5f9060397d SHA512 7554088ec62ca5b8335052c6651150ea2943e9933c3f8a3b4fc8bc4fb8e23ce4cbda13289d9be4da016a040c0ad7347b89a75a0353b59f022d8c26cd4f895238
MISC metadata.xml 392 BLAKE2B d2aa6fc43f7f9038d320197a18107f15e56ed5e242e6c3cdc1b7111184580ab14fae8cbd16776794d207dd39ea0ca65975c08a54449f4cf90370ea95a66083d9 SHA512 867c61c1e41d7594decd5e10a2b45d934313cb751ba22356fc1ab61e0a40b2543847b195d20c7a39ba92370d8b3908e6f90d690915579b55808872efe8d3cebe
diff --git a/net-misc/yt-dlp/yt-dlp-2024.09.27.ebuild b/net-misc/yt-dlp/yt-dlp-2024.09.27.ebuild
new file mode 100644
index 000000000000..b41167626f69
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2024.09.27.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+inherit bash-completion-r1 distutils-r1 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+SRC_URI="
+ https://github.com/yt-dlp/yt-dlp/releases/download/${PV}/${PN}.tar.gz
+ -> ${P}.tar.gz
+"
+S=${WORKDIR}/${PN}
+
+LICENSE="Unlicense"
+SLOT="0"
+# note that yt-dlp bumps are typically done straight-to-stable (unless there
+# was major/breaking changes) given website changes breaks it on a whim
+KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # adjust pycryptodome and drop optional dependencies (bug #828466)
+ sed -Ei pyproject.toml \
+ -e 's/("pycryptodome)x/\1/' \
+ -e '/"(brotli.*|certifi|mutagen|requests|urllib3|websockets)/d' || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fails with FEATURES=network-sandbox
+ test/test_networking.py::TestHTTPRequestHandler::test_connect_timeout
+ # fails with FEATURES=distcc, bug #915614
+ test/test_networking.py::TestYoutubeDLNetworking::test_proxy\[None-expected2\]
+ )
+
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+ optfeature "decrypting cookies from Chromium-based browsers" dev-python/secretstorage
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}