summaryrefslogtreecommitdiff
path: root/net-misc/you-get/you-get-0.4.1650-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-22 12:05:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-22 12:05:36 +0100
commit02eb6576978c38afed5787f6f2dbab8353379d66 (patch)
tree0b82220aae58c1307bef3aff0f342f4cdf858161 /net-misc/you-get/you-get-0.4.1650-r1.ebuild
parent490ef2c2dc8b4e808f37add1adee21a754efd9a9 (diff)
gentoo auto-resync : 22:04:2024 - 12:05:36
Diffstat (limited to 'net-misc/you-get/you-get-0.4.1650-r1.ebuild')
-rw-r--r--net-misc/you-get/you-get-0.4.1650-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-misc/you-get/you-get-0.4.1650-r1.ebuild b/net-misc/you-get/you-get-0.4.1650-r1.ebuild
new file mode 100644
index 000000000000..3d5b58a7cb5c
--- /dev/null
+++ b/net-misc/you-get/you-get-0.4.1650-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Utility to download media contents from the web"
+HOMEPAGE="https://you-get.org"
+SRC_URI="https://github.com/soimort/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT="test"
+PROPERTIES="test_network"
+
+RDEPEND="
+ media-video/ffmpeg
+"
+
+PATCHES=( "${FILESDIR}/${PN}-python3.12.patch" )
+
+distutils_enable_tests unittest