summaryrefslogtreecommitdiff
path: root/net-misc/wol/wol-0.7.1-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-29 16:01:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-29 16:01:29 +0100
commit9cd7e710ac676c1a318d09e665ca3558bb5c5323 (patch)
treee9be71b324835aa5fe0d86769dc47ba880e3313b /net-misc/wol/wol-0.7.1-r4.ebuild
parent8ba401288d74259a5fd8e9de5241dd57a0a73b1f (diff)
gentoo auto-resync : 29:10:2022 - 16:01:29
Diffstat (limited to 'net-misc/wol/wol-0.7.1-r4.ebuild')
-rw-r--r--net-misc/wol/wol-0.7.1-r4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-misc/wol/wol-0.7.1-r4.ebuild b/net-misc/wol/wol-0.7.1-r4.ebuild
new file mode 100644
index 000000000000..1ead57765ef2
--- /dev/null
+++ b/net-misc/wol/wol-0.7.1-r4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Implements Wake On LAN (Magic Paket) functionality in a small program"
+HOMEPAGE="http://ahh.sourceforge.net/wol/"
+SRC_URI="mirror://sourceforge/ahh/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~sparc x86"
+IUSE="nls"
+
+PATCHES=(
+ "${FILESDIR}/${P}-musl.patch"
+ "${FILESDIR}/${P}-Fix-config.h-test-consumption.patch"
+ "${FILESDIR}/${P}-Fix-malloc-detection.patch"
+ "${FILESDIR}/${P}-linux-headers.patch"
+)
+
+src_prepare() {
+ default
+
+ # bug #874420
+ eautoreconf
+}
+
+src_configure() {
+ export jm_cv_func_working_{re,m}alloc=yes
+
+ local myeconfargs=(
+ --disable-rpath
+ $(use_enable nls)
+ )
+
+ econf ${myeconfargs[@]}
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}