summaryrefslogtreecommitdiff
path: root/net-misc/wget
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /net-misc/wget
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'net-misc/wget')
-rw-r--r--net-misc/wget/Manifest2
-rw-r--r--net-misc/wget/wget-1.21.3.ebuild108
2 files changed, 110 insertions, 0 deletions
diff --git a/net-misc/wget/Manifest b/net-misc/wget/Manifest
index 396c49a6c096..a42832414a58 100644
--- a/net-misc/wget/Manifest
+++ b/net-misc/wget/Manifest
@@ -1,3 +1,5 @@
DIST wget-1.21.2.tar.gz 5004576 BLAKE2B e11c3a2b89ab26834dc4cbb445bcc6122d3a6b2a5b9c6de1ce9e8f062281f9e5aa1f80ca37a44791ba5aaf6a447015a26afef2199cdb75f1931d5e1ffb1f406b SHA512 3e35f92604486ca459f26df97d392579f1d83a9254519e8ce249b410bacf70dddf716d6caa3b29fd4865163f60410b2b8ad1ca1f7bb3dbb2456386b7647b988d
+DIST wget-1.21.3.tar.gz 5079864 BLAKE2B 4ff40a30cb3be82ea492d0eae324a9d43de30a0169d3b219ce25f3d667915f90c7eb1559760d1605340f112e96e028613265e0be73aaba7935c69cc06a4ae4f6 SHA512 29889ecbf590dff0f39183d9e0621741d731a554d990e5c995a4644725dca62e8e19601d40db0ef7d62ebf54e5457c7409965e4832b6e60e4ccbc9c8caa30718
EBUILD wget-1.21.2.ebuild 2873 BLAKE2B b0ca4fa3105c73c9623e788863cd6c46b6da3d4d2f7f158538a7b5468560648d89bfef1900818ddf64343cc8e5d3675b1324835c30964767b51fab2c94e44e90 SHA512 4c2c0e9751fd37ce85be5c9abfa028f0813d17b7d0c902792406e4a94c30590781d00d243e936fd4a107090921d5ec4023c358e712c84aed44bb99d6982936b9
+EBUILD wget-1.21.3.ebuild 3017 BLAKE2B cff69c528c34440837b4b640048b5a69e8647b08894a8d6f47ba9536a22f38ee0c4ba70090674e227848d8df344dd1921338d2c985bc7abfe0c53a228a4d9a1f SHA512 68f1e27eb77b9d0f142eaae57792c46a3f2e55fdc2d836a199fc433fc201e8fbbf64a1cd7657b8273fa52458db5aebc5a98e080bbd9583df2be56a53f0121349
MISC metadata.xml 740 BLAKE2B 1b36b1f6e8add5fcbbc757974dd8d9f89b4fb62ad1cdde882ec464e2348773e28f923c89259fa56b8d080be1b1975d91c113e4f10553fdd87c3d270bf29c393d SHA512 25e2e34967bd2a04f5aae19849353c798084031888a3aa300a4f9d4ef9029c41a4cc013a842c906dcc2720af155085e047ed99e45a102589f59625bc60042238
diff --git a/net-misc/wget/wget-1.21.3.ebuild b/net-misc/wget/wget-1.21.3.ebuild
new file mode 100644
index 000000000000..9dd6a70e4a1b
--- /dev/null
+++ b/net-misc/wget/wget-1.21.3.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit flag-o-matic python-any-r1 toolchain-funcs
+
+DESCRIPTION="Network utility to retrieve files from the WWW"
+HOMEPAGE="https://www.gnu.org/software/wget/"
+SRC_URI="mirror://gnu/wget/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="cookie-check debug gnutls idn ipv6 metalink nls ntlm pcre +ssl static test uuid zlib"
+REQUIRED_USE="ntlm? ( !gnutls ssl ) gnutls? ( ssl )"
+RESTRICT="!test? ( test )"
+
+# * Force a newer libidn2 to avoid libunistring deps. #bug #612498
+# * Metalink can use gpgme automagically (so let's always depend on it)
+# for signed metalink resources.
+LIB_DEPEND="
+ cookie-check? ( net-libs/libpsl )
+ idn? ( >=net-dns/libidn2-0.14:=[static-libs(+)] )
+ metalink? (
+ app-crypt/gpgme
+ media-libs/libmetalink
+ )
+ pcre? ( dev-libs/libpcre2[static-libs(+)] )
+ ssl? (
+ gnutls? ( net-libs/gnutls:=[static-libs(+)] )
+ !gnutls? ( dev-libs/openssl:=[static-libs(+)] )
+ )
+ uuid? ( sys-apps/util-linux[static-libs(+)] )
+ zlib? ( sys-libs/zlib[static-libs(+)] )
+"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="
+ ${RDEPEND}
+ static? ( ${LIB_DEPEND} )
+"
+BDEPEND="
+ app-arch/xz-utils
+ dev-lang/perl
+ sys-apps/texinfo
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ test? (
+ ${PYTHON_DEPS}
+ dev-perl/HTTP-Daemon
+ dev-perl/HTTP-Message
+ dev-perl/IO-Socket-SSL
+ )
+"
+
+DOCS=( AUTHORS MAILING-LIST NEWS README )
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ sed -i -e "s:/usr/local/etc:${EPREFIX}/etc:g" doc/{sample.wgetrc,wget.texi} || die
+}
+
+src_configure() {
+ # fix compilation on Solaris, we need filio.h for FIONBIO as used in
+ # the included gnutls -- force ioctl.h to include this header
+ [[ ${CHOST} == *-solaris* ]] && append-cppflags -DBSD_COMP=1
+
+ if use static ; then
+ append-ldflags -static
+ tc-export PKG_CONFIG
+ PKG_CONFIG+=" --static"
+ fi
+
+ # There is no flag that controls this. libunistring-prefix only
+ # controls the search path (which is why we turn it off below).
+ # Further, libunistring is only needed w/older libidn2 installs,
+ # and since we force the latest, we can force off libunistring. # bug #612498
+ local myeconfargs=(
+ ac_cv_libunistring=no
+ --disable-assert
+ --disable-pcre
+ --disable-rpath
+ --without-included-libunistring
+ --without-libunistring-prefix
+ $(use_enable debug)
+ $(use_enable idn iri)
+ $(use_enable ipv6)
+ $(use_enable nls)
+ $(use_enable ntlm)
+ $(use_enable pcre pcre2)
+ $(use_enable ssl digest)
+ $(use_enable ssl opie)
+ $(use_with cookie-check libpsl)
+ $(use_enable idn iri)
+ $(use_with metalink)
+ $(use_with ssl ssl $(usex gnutls gnutls openssl))
+ $(use_with uuid libuuid)
+ $(use_with zlib)
+ )
+
+ econf "${myeconfargs[@]}"
+}