summaryrefslogtreecommitdiff
path: root/net-misc/vrrpd/files/vrrpd-1.9-rollup.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/vrrpd/files/vrrpd-1.9-rollup.patch
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/vrrpd/files/vrrpd-1.9-rollup.patch')
-rw-r--r--net-misc/vrrpd/files/vrrpd-1.9-rollup.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/vrrpd/files/vrrpd-1.9-rollup.patch b/net-misc/vrrpd/files/vrrpd-1.9-rollup.patch
new file mode 100644
index 000000000000..72c5f3ad47f3
--- /dev/null
+++ b/net-misc/vrrpd/files/vrrpd-1.9-rollup.patch
@@ -0,0 +1,37 @@
+This is a partial rollup of patches submitted to upstream to clean up the
+packaging.
+
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+diff --git a/Makefile b/Makefile
+old mode 100755
+new mode 100644
+index d7f3309..869d06d
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,8 @@
+ PROJECT=vrrpd
+
+-ALL_EXE=vrrpd
++ALL_EXE=vrrpd atropos
+
++ATROPOS_OBJS = atropos.o
+ VRRPD_OBJS = vrrpd.o libnetlink.o ipaddr.o
+
+ MAIN_OPT=
+@@ -18,9 +19,13 @@ COMMON_CFLAGS= $(MAIN_OPT) $(INCLUDEOPT) $(PROF_OPT) $(DBG_OPT) $(MACHINEOPT)
+ CC=gcc
+ CFLAGS= $(COMMON_CFLAGS) -Wall
+
++all: $(ALL_EXE)
++
++atropos: $(ATROPOS_OBJS)
++ $(CC) $(PROF_OPT) -o $@ $^
++
+ vrrpd : $(VRRPD_OBJS)
+- $(CC) $(PROF_OPT) -o $@ $(VRRPD_OBJS) $(LINKLIB)
+- $(CC) atropos.c -o atropos
++ $(CC) $(PROF_OPT) -o $@ $^ $(LINKLIB)
+
+ vrrpd.o: vrrpd.h
+ libnetlink.o: libnetlink.h