summaryrefslogtreecommitdiff
path: root/net-misc/vncsnapshot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-25 01:25:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-25 01:25:44 +0100
commitc25088d4fc442a7d6dc3a8d0498b43024888318d (patch)
treefdb19b6a9b3a20669ecb49f0ba8d9f435fbb4b1a /net-misc/vncsnapshot
parentd80b870c42fbe218389ffaf86f0f2a39404deca1 (diff)
gentoo auto-resync : 25:09:2024 - 01:25:44
Diffstat (limited to 'net-misc/vncsnapshot')
-rw-r--r--net-misc/vncsnapshot/Manifest1
-rw-r--r--net-misc/vncsnapshot/vncsnapshot-1.2a-r1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-misc/vncsnapshot/Manifest b/net-misc/vncsnapshot/Manifest
index cee636dc0b84..26c1e00388ef 100644
--- a/net-misc/vncsnapshot/Manifest
+++ b/net-misc/vncsnapshot/Manifest
@@ -1,4 +1,5 @@
AUX vncsnapshot-1.2a-amd64grey.patch 312 BLAKE2B 573ec5b25b6829f3702c3f6e1c26160c89edf043ffa59e90e6d4664d51e124dfe688a282ab252f112a55e9eb5df31a2c1e205b7287bc0e8805f005288f29588c SHA512 73065578ac7cc52dbee7043feeea9bab3ec37ed4b0264232fcc531247a685feb41891588141863f861881b982be25db957d0c65ff23775ebcdddeabeaace6d7a
DIST vncsnapshot-1.2a-src.tar.bz2 70121 BLAKE2B 91e2d1e998f102707e00e5e83e9060fa88f1140b64029564977b93ac5b701be3408540ef76addf4ddf2cccfa973c59f94a127c74f44143c3683e38b0e9359c6d SHA512 2ae53a043c11d02bbb7ff6afc000eef268448643ba1db7b6c5a55fe3e25e65e1b22e64e855d33dfe55b1df04dc57f592e48c44918943642da19f7d06df77027c
+EBUILD vncsnapshot-1.2a-r1.ebuild 1267 BLAKE2B d2feca39a1d8bec2550b4f19384f467cccb1b7bacd536c5811d49890fc3f115814d5a8795e81f87e0527223d95efa0f1ec4d25bf06effccdaeb73fef0ee82e3b SHA512 5ba7fb62249ba439b683a9a7229229558b15797b48cda05271a0de7cc2ba4c4df3eca0ddc41a22eaaa5a678b95d198f187f3b4f633413424d6b797b9b8429ddf
EBUILD vncsnapshot-1.2a.ebuild 1251 BLAKE2B 7ba336d3245e3404e4292fa951a836af9ae0cfda144a18fe2dd579d167acd2e405b062651642965a72f48d65be24fa6f24b3e95acbde4e6d8231152ff26f37c6 SHA512 d8f43b7fbe754e2d4ab2d01fe95659106921ea97ba3ecc99365dec168db487c7f0fc357b2099eeaae09078ceffe3bd7398874bd1616572dc27def8e55d3cedeb
MISC metadata.xml 249 BLAKE2B de21f79d81f60af5286e45d77ea4badf023f24a6bcf35b636ac0cbcb078333fb76e64047f95e386439f2a0481e241f994794f281e6099992ebbe1b8f03da701b SHA512 4629240a2f020dae0d03c273c695cf068cbb9736584caaad9bcb15c175b5d9dc3e8a5fdb9d104c9fa0432b887f16f3d68bee70f52767f6b8125faa7162a269f5
diff --git a/net-misc/vncsnapshot/vncsnapshot-1.2a-r1.ebuild b/net-misc/vncsnapshot/vncsnapshot-1.2a-r1.ebuild
new file mode 100644
index 000000000000..766b4da94e0b
--- /dev/null
+++ b/net-misc/vncsnapshot/vncsnapshot-1.2a-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Command-line tool for taking JPEG snapshots of VNC servers"
+HOMEPAGE="https://vncsnapshot.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+
+DEPEND="
+ media-libs/libjpeg-turbo:=
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-amd64grey.patch"
+)
+
+src_prepare() {
+ default
+
+ sed \
+ -e 's:-I/usr/local/include::g' \
+ -e 's:-L/usr/local/lib::g' \
+ -e '/^all:/s|$(SUBDIRS:.dir=.all)||g' \
+ -e '/^vnc/s|$| $(SUBDIRS:.dir=.all)|g' \
+ -i Makefile || die
+
+ # Preserve make instance
+ sed -i -e 's/make/$(MAKE)/' Makefile || die
+
+ # Respect RANLIB
+ sed -i -e 's/ranlib/$(RANLIB)/' rdr/Makefile || die
+}
+
+src_compile() {
+ # We override CDEBUGFLAGS instead of CFLAGS because otherwise
+ # we lose the INCLUDES in the makefile. The same flags are used
+ # for both.
+ # bug #295741
+ local args=(
+ AR="$(tc-getAR)"
+ CDEBUGFLAGS="${CXXFLAGS}"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ RANLIB="$(tc-getRANLIB)"
+ )
+ emake "${args[@]}"
+}
+
+src_install() {
+ dobin vncsnapshot
+ newman vncsnapshot.man1 vncsnapshot.1
+}