summaryrefslogtreecommitdiff
path: root/net-misc/vino
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /net-misc/vino
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'net-misc/vino')
-rw-r--r--net-misc/vino/Manifest3
-rw-r--r--net-misc/vino/files/vino-return-error-if-X11-is-no-detected.patch41
-rw-r--r--net-misc/vino/files/vino-segfaults-on-wayland.patch30
-rw-r--r--net-misc/vino/vino-3.22.0-r1.ebuild72
4 files changed, 146 insertions, 0 deletions
diff --git a/net-misc/vino/Manifest b/net-misc/vino/Manifest
index ee6ea0ad988e..705c11f73431 100644
--- a/net-misc/vino/Manifest
+++ b/net-misc/vino/Manifest
@@ -1,3 +1,6 @@
+AUX vino-return-error-if-X11-is-no-detected.patch 1102 BLAKE2B 145b468e06bfa8b7abb18c1209761a2ca2314ffc92f04fe419ef0722eaed6a30b5a2e8cbeb8923e1b0cf072ba988ea9c3031fe2816df8632c3e123f643c70221 SHA512 6342507c051d81fbcbf8d2f8ce5005b60da0ba6a1f725c3aabb164c310b7c17a92f1aaeedc69873b47ba35041ff5ab7d75b762d5f9bfa70d967864e3cafb2596
+AUX vino-segfaults-on-wayland.patch 1172 BLAKE2B c8e3b9316309f78975123cd3ac87fd53d8fd498be5927a2188dfbddf5ac5316febf71ff5297466e95d079e9dfe8bf4a034c1b45320000c683f5e264527a870dd SHA512 e1d9a489643ce46259ebd830ccd906dbe65675ff57cb2d405b584acbf6c67e3a3f34f051c6ab5bd5fb5d40bd873225b36801b87030c30c0c764d3d5a72095f23
DIST vino-3.22.0.tar.xz 768716 BLAKE2B 5c3f6df059f129009bbc97527d1767bc8a29d8cbff5e6f9e89dabc4583ffdae2cf235eec66cbcb5f9e73c9a0a7c05a504e4e90221bf5adfc2ecbbbd518fdc84a SHA512 29b88e151b0b8c69bce1565ae3ec2e788f48c7645429984329fb2d3daaf03cc5ac100abbf70247bf0516c6d03a3b9aeb78d018c8f1bf35fd241919117fd1105f
+EBUILD vino-3.22.0-r1.ebuild 1826 BLAKE2B 85fb2ff4fd4fb836446af3f811d2935d3d2e27bf218add0123f3088c2813166fde1cd8e5497a1dd7496daa64da262c1f353d019c0d3944a9d861cba11eae01bc SHA512 06302279add1afa2b9f8ce1f2cc3dddba599c8aee7bbdd5874b0149ee2a2e03aae19d015abf001019599514077d4acd99b3415e41ee04b454eeb2f837c588d1c
EBUILD vino-3.22.0.ebuild 1651 BLAKE2B 345994ec32582e2fd99fba1dd860557119976ab09dd34aff5ea8aa01c9cf6658181522178cc8818f39114452016c172331fe0055edebbf333d80732d8e9145e3 SHA512 5d2e83be516cde4164c4c5a5067ab789ebd95fcc0133680cf2714db10677728fca0ce70d2d3790e236315399098df532610a0a0f74b3ca7585b9daec09b4c1ae
MISC metadata.xml 343 BLAKE2B 92816370ecc7d4e3b9d3f4513ee7c437b98ea3ca798107beb1b4885ab778768e19a20dbf8a3c19dd1c6d2b812a2498a9d1e2b4f4211dad0f350f620420a523e2 SHA512 dc33b648174ba60a62212dd252f1d358ee7a05ddbd41ae2b31dbdf362f4f780207c5183c0b180d68c8df5a613e91c1336231f2d75100076a01517e4d70d8252d
diff --git a/net-misc/vino/files/vino-return-error-if-X11-is-no-detected.patch b/net-misc/vino/files/vino-return-error-if-X11-is-no-detected.patch
new file mode 100644
index 000000000000..171d8590e3c9
--- /dev/null
+++ b/net-misc/vino/files/vino-return-error-if-X11-is-no-detected.patch
@@ -0,0 +1,41 @@
+From 5e49ab2d125388b843eca4f1f47849d18ccabcd3 Mon Sep 17 00:00:00 2001
+From: Ondrej Holy <oholy@redhat.com>
+Date: Tue, 20 Feb 2018 12:26:18 +0100
+Subject: [PATCH] Return error if X11 is not detected
+
+Vino-server crashes on Wayland in XQueryExtension. Since vino-server is
+not expected to work on displays other than X11, let's exit immediately
+if GDK_IS_X11_DISPLAY fail.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=761120
+---
+ server/vino-main.c | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/server/vino-main.c b/server/vino-main.c
+index dd95de7..7be3fff 100644
+--- a/server/vino-main.c
++++ b/server/vino-main.c
+@@ -28,6 +28,7 @@
+ #include <glib/gi18n.h>
+ #include <gtk/gtk.h>
+ #include <locale.h>
++#include <gdk/gdkx.h>
+
+ #include "vino-input.h"
+ #include "vino-mdns.h"
+@@ -273,6 +274,12 @@ main (int argc, char **argv)
+ g_option_context_free (context);
+ }
+
++ if (!GDK_IS_X11_DISPLAY (gdk_display_get_default ()))
++ {
++ g_printerr ("X11 is not detected\n");
++ return 1;
++ }
++
+ /* GSettings */
+ vino.settings = g_settings_new ("org.gnome.Vino");
+
+--
+2.16.2
diff --git a/net-misc/vino/files/vino-segfaults-on-wayland.patch b/net-misc/vino/files/vino-segfaults-on-wayland.patch
new file mode 100644
index 000000000000..ee161ae6fb98
--- /dev/null
+++ b/net-misc/vino/files/vino-segfaults-on-wayland.patch
@@ -0,0 +1,30 @@
+From c5e3011b7364729fa2cd4f11761bf1f001a931a4 Mon Sep 17 00:00:00 2001
+From: Ondrej Holy <oholy@redhat.com>
+Date: Tue, 22 May 2018 20:45:45 +0200
+Subject: [PATCH] Do not restart service after unclean exit code
+
+Currently, the vino-server.service has Restart=on-failure, which means
+that it is restarted in abnormal cases, but also in case of non-zero
+exit code. It is restarted 5 times e.g. in case when X11 is not detected,
+which doesn't make sense. Non-zero exit code is used only for states
+which won't change with restart (invalid commandline, wayland and some
+sanity checks). Change the value to Restart=on-abnormal in order to
+prevent the useless restarts and to not spam journal.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=761120
+---
+ server/vino-server.service.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/server/vino-server.service.in b/server/vino-server.service.in
+index a48b813..49e9c1f 100644
+--- a/server/vino-server.service.in
++++ b/server/vino-server.service.in
+@@ -5,4 +5,4 @@ Description=Vino VNC server
+ Type=dbus
+ BusName=org.gnome.Vino
+ ExecStart=@libexecdir@/vino-server
+-Restart=on-failure
++Restart=on-abnormal
+--
+2.17.0
diff --git a/net-misc/vino/vino-3.22.0-r1.ebuild b/net-misc/vino/vino-3.22.0-r1.ebuild
new file mode 100644
index 000000000000..9f17a92230a7
--- /dev/null
+++ b/net-misc/vino/vino-3.22.0-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2 systemd
+
+DESCRIPTION="An integrated VNC server for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/Vino"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="crypt debug gnome-keyring ipv6 jpeg ssl systemd +telepathy zeroconf +zlib"
+# bug #394611; tight encoding requires zlib encoding
+REQUIRED_USE="jpeg? ( zlib )"
+
+# cairo used in vino-fb
+# libSM and libICE used in eggsmclient-xsmp
+RDEPEND="
+ >=dev-libs/glib-2.26:2
+ >=dev-libs/libgcrypt-1.1.90:0=
+ >=x11-libs/gtk+-3:3
+
+ x11-libs/cairo:=
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXtst
+ x11-libs/pango[X]
+
+ >=x11-libs/libnotify-0.7.0:=
+
+ crypt? ( >=dev-libs/libgcrypt-1.1.90:0= )
+ gnome-keyring? ( app-crypt/libsecret )
+ jpeg? ( virtual/jpeg:0= )
+ ssl? ( >=net-libs/gnutls-2.2.0:= )
+ systemd? ( sys-apps/dbus[user-session] )
+ telepathy? (
+ dev-libs/dbus-glib
+ >=net-libs/telepathy-glib-0.18 )
+ zeroconf? ( >=net-dns/avahi-0.6:=[dbus] )
+ zlib? ( sys-libs/zlib:= )
+"
+DEPEND="${RDEPEND}
+ app-crypt/libsecret
+ dev-util/glib-utils
+ >=dev-util/intltool-0.50
+ virtual/pkgconfig
+"
+# libsecret is always required at build time per bug 322763
+
+PATCHES=(
+ "${FILESDIR}/${PN}-segfaults-on-wayland.patch"
+ "${FILESDIR}/${PN}-return-error-if-X11-is-no-detected.patch"
+)
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable ipv6) \
+ $(use_with crypt gcrypt) \
+ $(usex debug --enable-debug=yes ' ') \
+ $(use_with gnome-keyring secret) \
+ $(use_with jpeg) \
+ $(use_with ssl gnutls) \
+ $(use_with telepathy) \
+ $(use_with zeroconf avahi) \
+ $(use_with zlib) \
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+}