summaryrefslogtreecommitdiff
path: root/net-misc/utelnetd/utelnetd-0.1.11-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-16 10:42:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-16 10:42:35 +0100
commit4c16e0a214824f15f09396e359db4f1f5c086fec (patch)
treebfacafd52495915db60285b30438af8bc216d18a /net-misc/utelnetd/utelnetd-0.1.11-r4.ebuild
parent668b36c015ae61191cf7d5007b0afdbdcedab441 (diff)
gentoo auto-resync : 16:07:2023 - 10:42:35
Diffstat (limited to 'net-misc/utelnetd/utelnetd-0.1.11-r4.ebuild')
-rw-r--r--net-misc/utelnetd/utelnetd-0.1.11-r4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/utelnetd/utelnetd-0.1.11-r4.ebuild b/net-misc/utelnetd/utelnetd-0.1.11-r4.ebuild
new file mode 100644
index 000000000000..f1f5d885bfca
--- /dev/null
+++ b/net-misc/utelnetd/utelnetd-0.1.11-r4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Small telnet daemon derived from the Axis tools"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~s390 ~sparc ~x86"
+
+RDEPEND="sys-apps/shadow"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.1.11-musl-getgt.patch
+)
+
+src_prepare() {
+ default
+
+ sed -e "/(STRIP)/d" \
+ -e "/^CC/s|=.*|= $(tc-getCC)|" \
+ -e "/fomit-frame-pointer/d" \
+ -i Makefile || die
+
+ append-cppflags -D_GNU_SOURCE #871195
+}
+
+src_install() {
+ dosbin utelnetd
+ einstalldocs
+
+ newinitd "${FILESDIR}"/utelnetd.initd utelnetd
+}