summaryrefslogtreecommitdiff
path: root/net-misc/usbip/usbip-5.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /net-misc/usbip/usbip-5.15.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'net-misc/usbip/usbip-5.15.ebuild')
-rw-r--r--net-misc/usbip/usbip-5.15.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-misc/usbip/usbip-5.15.ebuild b/net-misc/usbip/usbip-5.15.ebuild
new file mode 100644
index 000000000000..3fcee65007b6
--- /dev/null
+++ b/net-misc/usbip/usbip-5.15.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ETYPE="sources"
+K_NOUSENAME=1
+inherit autotools kernel-2
+
+DESCRIPTION="Userspace utilities for a general USB device sharing system over IP networks"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI="${KERNEL_URI}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="tcpd"
+
+RDEPEND="
+ >=dev-libs/glib-2.6
+ sys-apps/hwdata
+ >=sys-kernel/linux-headers-3.17
+ virtual/libudev
+ tcpd? ( sys-apps/tcp-wrappers )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/linux-${PV}/tools/usb/${PN}"
+
+src_unpack() {
+ tar xJf "${DISTDIR}"/${A} linux-${PV}/tools/usb/${PN} || die
+}
+
+src_prepare() {
+ default
+ # remove -Werror from build, bug #545398
+ sed -i 's/-Werror[^ ]* //g' configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use tcpd || echo --without-tcp-wrappers) \
+ --with-usbids-dir="${EPREFIX}"/usr/share/hwdata
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "For using USB/IP you need to enable USBIP_VHCI_HCD in the client"
+ elog "machine's kernel config and USBIP_HOST on the server."
+}