summaryrefslogtreecommitdiff
path: root/net-misc/tuba
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-12 11:25:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-12 11:25:13 +0000
commitc9818073ff1b4fa99a5b484aa5f5e02d4aa487b9 (patch)
treed3a9f25e0d8635674d2b985d0ec81b36791f4d10 /net-misc/tuba
parent343576b60d95d89e6165d24813c57e3bd92d3911 (diff)
gentoo auto-resync : 12:12:2023 - 11:25:13
Diffstat (limited to 'net-misc/tuba')
-rw-r--r--net-misc/tuba/Manifest1
-rw-r--r--net-misc/tuba/tuba-9999.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/net-misc/tuba/Manifest b/net-misc/tuba/Manifest
index 387a081e09bf..dbd6bbdd2f52 100644
--- a/net-misc/tuba/Manifest
+++ b/net-misc/tuba/Manifest
@@ -1,3 +1,4 @@
DIST Tuba-0.5.0.gh.tar.gz 1022753 BLAKE2B d17fed8b93d217a26ad38e3a0a1e576e34b309e80e445dab7054c999eadd78ed579a81af3971ecbe3cdb5f29ea7fd0ae60c2fbcd65b5591a375ad2e38c476d87 SHA512 220cd905d82711dd915bb8dfebb9ca8d840cca3ca707cea0bc1b0b78c27dc2fbf37e779ebfeb4aff123bcda4d2b59786169f8645585868498cca2bb7a87904f1
EBUILD tuba-0.5.0.ebuild 1433 BLAKE2B 22fd47cfe7f83efd265d49840b66f96cb9d7ee2c8508efe9edce14b0d896b113bb3491e0a03d0d121d2fa966d7c04b10a761a1e00490228557741bdf2491ff84 SHA512 57875c76cb2c31b8e100969fc914fd40b3f665ae0e8290f961cd75fc5c2e5d9c5ac64c540063098075881643e85bc0bfd3ea18c158e61b1d17177ff5bc1c0dbc
+EBUILD tuba-9999.ebuild 1333 BLAKE2B a4a69c1e5c9d87edd6942573d6d00de2020a62a708eb7bb1ad14da9483305bb97de0688c70a2e59062effaabfae2b85ff7575a695c7051666574cf68ed147ca9 SHA512 d377b9123527ae2f9362bbe5ad6695851e8fd48e95e76d3002ed69c5a6c1ee24d8bcd71fa456744de90d7d4b4966e80b8ed55774e6a5f60a0c2a55f9fd363129
MISC metadata.xml 324 BLAKE2B b9364b6c365bfaeda33ec6e0600582271501e80f0af0c075545a9d577e823bc4ce35ec37903f2f7f1f22c016b6bb0e7c40ef7d9ba8882fb924a865491bbb8dc7 SHA512 867574ad6665a12cb09aa75c525de101955dabdea5b744e688ab0b7214482ca5d151ed2007c5b050fbc69c48205fdbe5784aea0cb7ebce455d785200048b0a41
diff --git a/net-misc/tuba/tuba-9999.ebuild b/net-misc/tuba/tuba-9999.ebuild
new file mode 100644
index 000000000000..94c20661a979
--- /dev/null
+++ b/net-misc/tuba/tuba-9999.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit git-r3 gnome2-utils meson optfeature vala
+
+DESCRIPTION="Browse the Fediverse (GTK client)"
+HOMEPAGE="
+ https://tuba.geopjr.dev/
+ https://github.com/GeopJr/Tuba/
+"
+EGIT_REPO_URI="https://github.com/GeopJr/Tuba.git"
+
+LICENSE="GPL-3 CC-BY-SA-4.0"
+SLOT="0"
+
+# TODO: optional dep on libspelling-1
+DEPEND="
+ app-crypt/libsecret[introspection]
+ >=dev-libs/glib-2.76.0:2
+ >=dev-libs/json-glib-1.4.4[introspection]
+ >=dev-libs/libgee-0.8.5:0.8[introspection]
+ dev-libs/libxml2
+ >=gui-libs/gtk-4.11.3:4[gstreamer,introspection]
+ >=gui-libs/libadwaita-1.4:1[introspection,vala]
+ >=gui-libs/gtksourceview-5.6.0:5[introspection,vala]
+ net-libs/libsoup:3.0[introspection]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ $(vala_depend)
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ # disable calling updaters (see pkg_post*)
+ -Ddistro=true
+ )
+
+ vala_setup
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dosym dev.geopjr.Tuba /usr/bin/tuba
+}
+
+pkg_postinst() {
+ optfeature "WebP image support" gui-libs/gdk-pixbuf-loader-webp
+
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}