summaryrefslogtreecommitdiff
path: root/net-misc/tuba
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-10 23:14:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-10 23:14:41 +0000
commit145b1805c3986974378af5c60767504ecc9ed280 (patch)
tree28dbd5be73a5af5dd20d4ea81d293394d975c9e0 /net-misc/tuba
parent627302fc2f41a621644260ffa3f50e06ea5edd60 (diff)
gentoo auto-resync : 10:12:2023 - 23:14:40
Diffstat (limited to 'net-misc/tuba')
-rw-r--r--net-misc/tuba/Manifest3
-rw-r--r--net-misc/tuba/metadata.xml11
-rw-r--r--net-misc/tuba/tuba-0.5.0.ebuild72
3 files changed, 86 insertions, 0 deletions
diff --git a/net-misc/tuba/Manifest b/net-misc/tuba/Manifest
new file mode 100644
index 000000000000..360715dfe78c
--- /dev/null
+++ b/net-misc/tuba/Manifest
@@ -0,0 +1,3 @@
+DIST Tuba-0.5.0.gh.tar.gz 1022753 BLAKE2B d17fed8b93d217a26ad38e3a0a1e576e34b309e80e445dab7054c999eadd78ed579a81af3971ecbe3cdb5f29ea7fd0ae60c2fbcd65b5591a375ad2e38c476d87 SHA512 220cd905d82711dd915bb8dfebb9ca8d840cca3ca707cea0bc1b0b78c27dc2fbf37e779ebfeb4aff123bcda4d2b59786169f8645585868498cca2bb7a87904f1
+EBUILD tuba-0.5.0.ebuild 1426 BLAKE2B 649c14971685064998179371073ed29fc91ff1a09055d6371e2caaa379c308785b6758996812849759fdca65594cbe81231512fa59942f17394c9a3f501afe3d SHA512 e02e1e5ddae7e71af98997a93efb67ab894a1e9168be4a977c4ec2c913ff500f205c01d2b41b93ab917a2442c05921a99638e934c29df437f876b3eae864f39a
+MISC metadata.xml 324 BLAKE2B b9364b6c365bfaeda33ec6e0600582271501e80f0af0c075545a9d577e823bc4ce35ec37903f2f7f1f22c016b6bb0e7c40ef7d9ba8882fb924a865491bbb8dc7 SHA512 867574ad6665a12cb09aa75c525de101955dabdea5b744e688ab0b7214482ca5d151ed2007c5b050fbc69c48205fdbe5784aea0cb7ebce455d785200048b0a41
diff --git a/net-misc/tuba/metadata.xml b/net-misc/tuba/metadata.xml
new file mode 100644
index 000000000000..a577af22922b
--- /dev/null
+++ b/net-misc/tuba/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">GeopJR/tuba</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/tuba/tuba-0.5.0.ebuild b/net-misc/tuba/tuba-0.5.0.ebuild
new file mode 100644
index 000000000000..d74b834ad83f
--- /dev/null
+++ b/net-misc/tuba/tuba-0.5.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson optfeature vala
+
+MY_P=${P^}
+DESCRIPTION="Browse the Fediverse (GTK client)"
+HOMEPAGE="
+ https://tuba.geopjr.dev/
+ https://github.com/GeopJr/Tuba/
+"
+SRC_URI="
+ https://github.com/GeopJr/Tuba/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3 CC-BY-SA-4.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# TODO: optional deps on gspell-4 & libspelling-1
+DEPEND="
+ app-crypt/libsecret[introspection]
+ >=dev-libs/glib-2.76.0:2
+ >=dev-libs/json-glib-1.4.4[introspection]
+ >=dev-libs/libgee-0.8.5:0.8[introspection]
+ dev-libs/libxml2
+ >=gui-libs/gtk-4.11.3:4[gstreamer,introspection]
+ >=gui-libs/libadwaita-1.4:1[introspection,vala]
+ >=gui-libs/gtksourceview-5.6.0:5[introspection,vala]
+ net-libs/libsoup:3.0[introspection]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ $(vala_depend)
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ # disable calling updaters (see pkg_post*)
+ -Ddistro=true
+ )
+
+ vala_setup
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dosym dev.geopjr.Tuba /usr/bin/tuba
+}
+
+pkg_postinst() {
+ optfeature "WebP image support" gui-libs/gdk-pixbuf-loader-webp
+
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}