summaryrefslogtreecommitdiff
path: root/net-misc/trurl/trurl-0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-04 05:21:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-04 05:21:45 +0100
commit41e5b5c1f11820df590e0a245bbddf224bc07823 (patch)
treefa24fa74d0d74130c20b3e25b975b21773018e0a /net-misc/trurl/trurl-0.2.ebuild
parent979898cb45139dd0e6727a01df15b602f74a8dd3 (diff)
gentoo auto-resync : 04:04:2023 - 05:21:44
Diffstat (limited to 'net-misc/trurl/trurl-0.2.ebuild')
-rw-r--r--net-misc/trurl/trurl-0.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/trurl/trurl-0.2.ebuild b/net-misc/trurl/trurl-0.2.ebuild
new file mode 100644
index 000000000000..d746c034e362
--- /dev/null
+++ b/net-misc/trurl/trurl-0.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Command line tool for URL parsing and manipulation"
+HOMEPAGE="https://daniel.haxx.se/blog/2023/04/03/introducing-trurl/ https://github.com/curl/trurl"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/curl/trurl"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/curl/trurl/archive/refs/tags/${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${P}
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="curl"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=net-misc/curl-7.62.0"
+RDEPEND="${DEPEND}"
+BDEPEND="test? ( dev-lang/perl )"
+
+src_compile() {
+ tc-export CC
+
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+}