summaryrefslogtreecommitdiff
path: root/net-misc/tigervnc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /net-misc/tigervnc/files
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'net-misc/tigervnc/files')
-rw-r--r--net-misc/tigervnc/files/tigervnc-1.11.0-install-java-viewer.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-misc/tigervnc/files/tigervnc-1.11.0-install-java-viewer.patch b/net-misc/tigervnc/files/tigervnc-1.11.0-install-java-viewer.patch
new file mode 100644
index 000000000000..3afaf82d0023
--- /dev/null
+++ b/net-misc/tigervnc/files/tigervnc-1.11.0-install-java-viewer.patch
@@ -0,0 +1,26 @@
+See bug for rationale, gist is that this is still useful.
+
+Patch from Erik Wallin <erikw@sizeit.se>
+https://bugs.gentoo.org/769794
+--- a/java/CMakeLists.txt
++++ b/java/CMakeLists.txt
+@@ -7,6 +7,8 @@
+
+ find_package(Java)
+
++set(DATA_DIR "${CMAKE_INSTALL_PREFIX}/share")
++
+ set(DEFAULT_JAVACFLAGS "-source 8 -target 8 -encoding UTF-8 -Xlint:all,-serial,-cast,-unchecked,-fallthrough,-dep-ann,-deprecation,-rawtypes")
+ set(JAVACFLAGS ${DEFAULT_JAVACFLAGS} CACHE STRING
+ "Java compiler flags (Default: ${DEFAULT_JAVACFLAGS})")
+@@ -172,3 +174,10 @@
+ -P ${SRCDIR}/cmake/SignJar.cmake)
+
+ add_custom_target(java ALL DEPENDS VncViewer.jar)
++
++if(NOT WIN32)
++ install(FILES
++ ${BINDIR}/VncViewer.jar
++ ${SRCDIR}/${CLASSPATH}/README
++ DESTINATION ${DATA_DIR}/vnc/classes)
++endif()