summaryrefslogtreecommitdiff
path: root/net-misc/streamlink
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-25 14:07:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-25 14:07:44 +0000
commit6a84e414622fd99c22318ce656a77bb2a0433fc7 (patch)
tree048f41d4a2a9c373e50bf0906c5508e6f5104fae /net-misc/streamlink
parenta1b20429e7e2ba1b44414459afd5a2b50788cd9c (diff)
gentoo auto-resync : 25:01:2023 - 14:07:44
Diffstat (limited to 'net-misc/streamlink')
-rw-r--r--net-misc/streamlink/Manifest2
-rw-r--r--net-misc/streamlink/streamlink-5.2.1.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/net-misc/streamlink/Manifest b/net-misc/streamlink/Manifest
index b8cce32d1394..5761c57da925 100644
--- a/net-misc/streamlink/Manifest
+++ b/net-misc/streamlink/Manifest
@@ -1,6 +1,8 @@
DIST streamlink-4.3.0.tar.gz 474184 BLAKE2B 557d70105f043fe7454d1c6dd7a49becfd354612df43d09242ec86da5275c7c629f6df887ee7e3a25d9c502e0845f38bece0da2335c5f09951cb4b0aada408a3 SHA512 e1c450d777c00515c07895303dccdece23a8a29b2f9cc272790f5d4b260adbb381845d7ffbc9425e6cee7be41d66158e226d14d08352430bff1c29889b0b0077
DIST streamlink-5.1.2.tar.gz 494342 BLAKE2B f916aab0fcd346e9945de04335309c61cb83c7c5047208a281a87162fb19dae6e45ae861fbc55780049e63bd854f303ee1669d3664a3736debbf8194ee4e6760 SHA512 8fecdc46fc34b37a5a67d15bb4252d1ebab69815398deb533de063fdf7e211d23d413b1b519984dddd2bb5e35296d717dd0504a3578b7bc44c7b123cd70db2a3
+DIST streamlink-5.2.1.tar.gz 510860 BLAKE2B eb7f3c85b048d3f274c332f27daafe38a0b495a651101ba2f7c19f13f18a8c691d495f614212dd610e80d0e80c23c695017a212760fe10dd58e00e9d8ac7f95f SHA512 68c02eaee2881f8777eaae3d0b54b0c6aeb0aabf76ab52ac23999895ed0d04a73d817634926869acbf8c092bbe65aadc9637824d56fc439d7445d2ea5f400764
EBUILD streamlink-4.3.0.ebuild 1395 BLAKE2B dba4163937369a5b50311ee57103cfe1408a857a93066a9881df0e4ef8c18b446df215904b7a1b713800272aac2ff201be5d98fe1142e218c676506d3c2d73c5 SHA512 b41080cc87d8f70c2ee6514a3407b83d55f583e82df31b8229d08f682021343fe9ca6e02c16a91cadfefcafd19fdfc0377450b6503ef880d05906f08d868d47e
EBUILD streamlink-5.1.2.ebuild 1529 BLAKE2B 958bfa808f760c61033d8bc314c2d457cbe40ab4f9453cadaf7d9ee8d23a64562a3a9ead3f5ac24516e147c69f1194dfdbdf0125d2af701a9eb87012ad1c7c87 SHA512 5e380040120a622ca487250b539b134e05fc717a234d9bc1d207c14d7e53414bff72c53bc5c378363ac860d3d437789c0baf2e65469dee4ea0ac92ba43ba598d
+EBUILD streamlink-5.2.1.ebuild 1529 BLAKE2B 958bfa808f760c61033d8bc314c2d457cbe40ab4f9453cadaf7d9ee8d23a64562a3a9ead3f5ac24516e147c69f1194dfdbdf0125d2af701a9eb87012ad1c7c87 SHA512 5e380040120a622ca487250b539b134e05fc717a234d9bc1d207c14d7e53414bff72c53bc5c378363ac860d3d437789c0baf2e65469dee4ea0ac92ba43ba598d
EBUILD streamlink-9999.ebuild 1529 BLAKE2B 958bfa808f760c61033d8bc314c2d457cbe40ab4f9453cadaf7d9ee8d23a64562a3a9ead3f5ac24516e147c69f1194dfdbdf0125d2af701a9eb87012ad1c7c87 SHA512 5e380040120a622ca487250b539b134e05fc717a234d9bc1d207c14d7e53414bff72c53bc5c378363ac860d3d437789c0baf2e65469dee4ea0ac92ba43ba598d
MISC metadata.xml 374 BLAKE2B 8c5f72454d8d00a99c18328838cc9c3be82cd9d68405f6e702239b8475a9162f3ba945b142bf2f5762fcc4ac52cae95c8e2d5c0707b1028c11faba2341a2d8e9 SHA512 038e509b340b1cc31382b0a1edf0c273fe99ca7c8c40370039a01cf6a95101d1217db7fea64bc67f5c113c99d504ceb7256008c1539c4d7e13ad6ceb8b922a58
diff --git a/net-misc/streamlink/streamlink-5.2.1.ebuild b/net-misc/streamlink/streamlink-5.2.1.ebuild
new file mode 100644
index 000000000000..ff7c51d0ed88
--- /dev/null
+++ b/net-misc/streamlink/streamlink-5.2.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/streamlink/${PN}.git"
+ inherit git-r3
+fi
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+inherit distutils-r1
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+
+if [[ ${PV} != 9999* ]]; then
+ SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2 Apache-2.0"
+SLOT="0"
+
+DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >dev-python/requests-2.21.0[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
+ >dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ ')
+"
+RDEPEND="${DEPEND}
+ media-video/ffmpeg
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+ ')"
+
+distutils_enable_tests pytest