summaryrefslogtreecommitdiff
path: root/net-misc/streamlink/streamlink-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/streamlink/streamlink-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/streamlink/streamlink-9999.ebuild')
-rw-r--r--net-misc/streamlink/streamlink-9999.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-misc/streamlink/streamlink-9999.ebuild b/net-misc/streamlink/streamlink-9999.ebuild
new file mode 100644
index 000000000000..4a297db743e5
--- /dev/null
+++ b/net-misc/streamlink/streamlink-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+EGIT_REPO_URI="https://github.com/${PN}/${PN}"
+
+KEYWORDS=""
+LICENSE="BSD-2 Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ dev-python/backports-shutil_which[$(python_gen_usedep 'python2*')]
+ dev-python/backports-shutil_get_terminal_size[$(python_gen_usedep 'python2*')]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ media-video/rtmpdump
+ virtual/ffmpeg"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}] )
+ test? ( dev-python/mock[$(python_gen_usedep 'python2*')]
+ ${RDEPEND} )"
+
+python_configure_all() {
+ # Avoid iso-639, iso3166 dependencies since we use pycountry.
+ export STREAMLINK_USE_PYCOUNTRY=1
+}
+
+python_compile_all() {
+ use doc && emake -C docs html man
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use doc; then
+ local HTML_DOCS=( docs/_build/html/. )
+ doman docs/_build/man/*
+ fi
+ distutils-r1_python_install_all
+}