summaryrefslogtreecommitdiff
path: root/net-misc/sslh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-17 09:07:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-17 09:07:15 +0000
commit9bd54251864651f49e673a08aec9ef79cfe08f04 (patch)
treebac28788ab54849c5d28edb190a687167737e736 /net-misc/sslh
parent6b933047f46efec1aa747570f945344254227457 (diff)
gentoo resync : 17.12.2017
Diffstat (limited to 'net-misc/sslh')
-rw-r--r--net-misc/sslh/Manifest3
-rw-r--r--net-misc/sslh/metadata.xml7
-rw-r--r--net-misc/sslh/sslh-9999.ebuild69
3 files changed, 78 insertions, 1 deletions
diff --git a/net-misc/sslh/Manifest b/net-misc/sslh/Manifest
index dad39c704b33..091d9086ed9a 100644
--- a/net-misc/sslh/Manifest
+++ b/net-misc/sslh/Manifest
@@ -4,4 +4,5 @@ AUX sslh.conf.d-2 297 BLAKE2B c59d4eb8dfd4c2ed6f3a952cd2764c11aea21c1c62e5a4ffc5
AUX sslh.init.d-2 465 BLAKE2B eb34383ade0d3fe778d11d098129f5466df15816ca8eb8eb7c5b2cb8eebee91195b0e3e9f9be4fa5f941f8aacbfbb4d718876a8e8af0c9a13c6dcdf2dc6d104b SHA512 73b38af0142f6d591d71531e03aca3ddf625faa7825a9951dc31112fa1bca5b28f8074a3f9ca565b2cd3995b635cc7818d899ce099d64d2eb97ff9cab2e617ba
DIST sslh-v1.18.tar.gz 53170 BLAKE2B 8d26bdc9950b9017279b36699821b756ea0507949edca90758cd4149aac56fd1a12e0192009ce2154af09818a6aa009fd2009f88d89dae8f76525d7aacc4a830 SHA512 3f0f61c340b689fb30015d5c73d6c29398b5c6a115ae9089d0b3c0230e99c90049df03133e4b0c3668fbfe995ed40cd3543c5764171c57e632e75bd5c3548fea
EBUILD sslh-1.18-r2.ebuild 1753 BLAKE2B be4845b0cfa8e7360cee513a1c570e1f86c061d578344929fceaffc1f1006b358dd21ba2c4ced28b68934d3c868c36e8e3d471cecc91fc6306ebf20610aec4fa SHA512 a4a96c61476381f0870b0cef1278219d555e7b6c8760c078a4772ab26550163ec991b57797362bf885d07331d4ceac5294180e868dbf65af9e9122da7e467ef7
-MISC metadata.xml 221 BLAKE2B 6d597a7a853603bd878e86c6552cb68211e81f627cdb673ae99dc6c6133f50f617101e43f4b4631b45b5969ee6ec42849b156a62594f939d00c112ce51d769e1 SHA512 e50d6cad26239ebf4260f0cf4bdf4e29ef2038e999039adf94f49b184b5993f02bb0d4cdb3de6c7b5cda99890db42dcd2b65c5342256be50dc19e6aab2406353
+EBUILD sslh-9999.ebuild 1822 BLAKE2B fff4484d47001abe61a2b8b2644f1a22d110c819b90910d4a96ba4bad9a78d858fdf32c3b5b84671171c975350fa4cc0bd436016a6540f4a105bff8811722b27 SHA512 027e715859cc789dbc180ea7a4dbd21580e54b05ffbb1c7b3372c3c05647c1e98f21cec1e88393908d342bfbd085cd7c5c5bded59e99ab376be89cdd3e98af04
+MISC metadata.xml 409 BLAKE2B fefa58b2c38adf947e859893979931726dba91e4b30c6f7ae4e5343fb7e7a513a3b86c88ff6854df60ba92ef169beb4e22c7ad3a01ba69aea582765f13f82509 SHA512 373b7ca5bce7d2b680a7ccfdc4af15514365cf26824487baf2232608a6f29a5d1d338146c7f70841e7b03255527ec16967afc7a3fad3ef6d26fb2ab86fe8a3da
diff --git a/net-misc/sslh/metadata.xml b/net-misc/sslh/metadata.xml
index 69570e849328..ed9a606540fa 100644
--- a/net-misc/sslh/metadata.xml
+++ b/net-misc/sslh/metadata.xml
@@ -4,4 +4,11 @@
<maintainer type="person">
<email>kensington@gentoo.org</email>
</maintainer>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">yrutschle/sslh</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/net-misc/sslh/sslh-9999.ebuild b/net-misc/sslh/sslh-9999.ebuild
new file mode 100644
index 000000000000..8f3831fefa9b
--- /dev/null
+++ b/net-misc/sslh/sslh-9999.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic systemd toolchain-funcs
+
+DESCRIPTION="Port multiplexer - accept both HTTPS and SSH connections on the same port"
+HOMEPAGE="http://www.rutschle.net/tech/sslh.shtml"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/yrutschle/sslh.git"
+ inherit git-r3
+else
+ KEYWORDS="amd64 ~arm ~m68k ~mips ~s390 ~sh x86"
+ MY_P="${PN}-v${PV}"
+ SRC_URI="http://www.rutschle.net/tech/${PN}/${MY_P}.tar.gz"
+ S=${WORKDIR}/${MY_P}
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="caps pcre systemd tcpd"
+
+RDEPEND="caps? ( sys-libs/libcap )
+ systemd? ( sys-apps/systemd:= )
+ tcpd? ( sys-apps/tcp-wrappers )
+ >=dev-libs/libconfig-1.5"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ pcre? ( dev-libs/libpcre:= )"
+
+RESTRICT="test"
+
+src_compile() {
+ # On older versions of GCC, the default gnu89 variant
+ # will reject within-for-loop initializers, bug #595426
+ # Furthermore, we need to use the gnu variant (gnu99) instead
+ # of the ISO (c99) variant, as we want the __USE_XOPEN2K macro
+ # to be defined.
+ append-cflags -std=gnu99
+
+ emake \
+ CC="$(tc-getCC)" \
+ USELIBPCRE=$(usev pcre) \
+ USELIBCAP=$(usev caps) \
+ USELIBWRAP=$(usev tcpd) \
+ USESYSTEMD=$(usev systemd)
+}
+
+src_install() {
+ dosbin sslh-{fork,select}
+ dosym sslh-fork /usr/sbin/sslh
+
+ gunzip ${PN}.8.gz
+ doman ${PN}.8
+
+ dodoc ChangeLog README.md
+
+ newinitd "${FILESDIR}"/sslh.init.d-2 sslh
+ newconfd "${FILESDIR}"/sslh.conf.d-2 sslh
+
+ if use systemd; then
+ # Gentoo puts the binaries in /usr/sbin, but upstream puts them in /usr/bin
+ sed -i -e 's~/usr/bin/~/usr/sbin/~g' scripts/systemd.sslh.service || die
+ systemd_newunit scripts/systemd.sslh.service sslh.service
+ exeinto /usr/lib/systemd/system-generators/
+ doexe systemd-sslh-generator
+ fi
+}