summaryrefslogtreecommitdiff
path: root/net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-1.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-1.0-r1.ebuild')
-rw-r--r--net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-1.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-1.0-r1.ebuild b/net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-1.0-r1.ebuild
new file mode 100644
index 000000000000..580ea00be4dc
--- /dev/null
+++ b/net-misc/ssh-askpass-fullscreen/ssh-askpass-fullscreen-1.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="A small SSH Askpass replacement written with GTK2"
+HOMEPAGE="https://github.com/atj/ssh-askpass-fullscreen"
+SRC_URI="mirror://github/atj/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.10.0:2
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # https://github.com/atj/ssh-askpass-fullscreen/pull/1
+ epatch "${FILESDIR}/${P}-libX11.patch"
+
+ # automake-1.13 fix, bug #468764
+ sed -i -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' configure.ac || die
+
+ eautoreconf
+}
+
+src_install() {
+ default
+ # Automatically display the passphrase dialog - see bug #437764
+ echo "SSH_ASKPASS='${EPREFIX}/usr/bin/ssh-askpass-fullscreen'" >> "${T}/99ssh_askpass" \
+ || die "envd file creation failed"
+ doenvd "${T}"/99ssh_askpass || die "doenvd failed"
+}