summaryrefslogtreecommitdiff
path: root/net-misc/socket-burst-dampener/socket-burst-dampener-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /net-misc/socket-burst-dampener/socket-burst-dampener-1.3.0.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'net-misc/socket-burst-dampener/socket-burst-dampener-1.3.0.ebuild')
-rw-r--r--net-misc/socket-burst-dampener/socket-burst-dampener-1.3.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/net-misc/socket-burst-dampener/socket-burst-dampener-1.3.0.ebuild b/net-misc/socket-burst-dampener/socket-burst-dampener-1.3.0.ebuild
new file mode 100644
index 000000000000..afe18fc2ea83
--- /dev/null
+++ b/net-misc/socket-burst-dampener/socket-burst-dampener-1.3.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A daemon that spawns one command per connection, and dampens connection bursts"
+HOMEPAGE="https://github.com/zmedico/socket-burst-damener"
+SRC_URI="https://github.com/zmedico/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i "s:^\(__version__ =\).*:\\1 \"${PV}\":" src/${PN//-/_}.py || die
+ distutils-r1_src_prepare
+}