summaryrefslogtreecommitdiff
path: root/net-misc/socat/socat-1.7.3.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /net-misc/socat/socat-1.7.3.4.ebuild
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'net-misc/socat/socat-1.7.3.4.ebuild')
-rw-r--r--net-misc/socat/socat-1.7.3.4.ebuild25
1 files changed, 14 insertions, 11 deletions
diff --git a/net-misc/socat/socat-1.7.3.4.ebuild b/net-misc/socat/socat-1.7.3.4.ebuild
index a364c0284ad1..3eba54db2ef8 100644
--- a/net-misc/socat/socat-1.7.3.4.ebuild
+++ b/net-misc/socat/socat-1.7.3.4.ebuild
@@ -1,18 +1,19 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit flag-o-matic toolchain-funcs
-DESCRIPTION="Multipurpose relay (SOcket CAT)"
-HOMEPAGE="http://www.dest-unreach.org/socat/"
MY_P=${P/_beta/-b}
-S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/ https://repo.or.cz/socat.git"
SRC_URI="http://www.dest-unreach.org/socat/download/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="bindist libressl ssl readline ipv6 tcpd"
DEPEND="
@@ -23,16 +24,17 @@ DEPEND="
readline? ( sys-libs/readline:= )
tcpd? ( sys-apps/tcp-wrappers )
"
-RDEPEND="
- ${DEPEND}
-"
+RDEPEND="${DEPEND}"
+
+# Tests are a large bash script
+# Hard to disable individual tests needing network or privileges
RESTRICT="
test
ssl? ( readline? ( bindist ) )
"
-DOCS=(
- BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY
-)
+
+DOCS=( BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY )
+
PATCHES=(
"${FILESDIR}"/${PN}-1.7.3.4-fno-common.patch
)
@@ -49,6 +51,7 @@ pkg_setup() {
src_configure() {
filter-flags '-Wno-error*' #293324
tc-export AR
+
econf \
$(use_enable ssl openssl) \
$(use_enable readline) \