summaryrefslogtreecommitdiff
path: root/net-misc/shigofumi/shigofumi-0.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-29 03:22:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-29 03:22:09 +0100
commitd4bd6695641f6d2ec7ff8681913d304e995902f5 (patch)
tree6ec8d4c38152bb4f2bb4b93277236ebd9fbbd21d /net-misc/shigofumi/shigofumi-0.3-r1.ebuild
parent22910f5d14da606bd7f06e19a2f61c5d1a8fc94b (diff)
gentoo resync : 29.05.2018
Diffstat (limited to 'net-misc/shigofumi/shigofumi-0.3-r1.ebuild')
-rw-r--r--net-misc/shigofumi/shigofumi-0.3-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/shigofumi/shigofumi-0.3-r1.ebuild b/net-misc/shigofumi/shigofumi-0.3-r1.ebuild
new file mode 100644
index 000000000000..1c7d25f0f8bd
--- /dev/null
+++ b/net-misc/shigofumi/shigofumi-0.3-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WANT_AUTOMAKE="1.11"
+inherit autotools
+
+DESCRIPTION="Command line client for ISDS"
+HOMEPAGE="http://xpisar.wz.cz/shigofumi/"
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI='git://repo.or.cz/shigofumi.git'
+ inherit git-r3
+else
+ SRC_URI="http://xpisar.wz.cz/${PN}/dist/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~mips ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug doc nls xattr"
+
+RDEPEND="
+ dev-libs/confuse:0=
+ dev-libs/libxml2:2
+ sys-libs/readline:0=
+ >=net-libs/libisds-0.7
+ xattr? ( sys-apps/attr )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ )
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ default
+ [[ ${PV} = 9999* ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-fatalwarnings \
+ $(use_enable debug) \
+ $(use_enable doc) \
+ $(use_enable nls) \
+ $(use_enable xattr)
+}