summaryrefslogtreecommitdiff
path: root/net-misc/seafile/seafile-8.0.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-23 19:09:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-23 19:09:12 +0000
commit89aeb05c8da1b0c32fb9d0cd5d202763780d5d5a (patch)
tree58e84b2fdeecbc82c9e04dc13de2d56ecc02d583 /net-misc/seafile/seafile-8.0.9.ebuild
parent87cdf8e64e5874146493d2a4a4489b08583043c3 (diff)
gentoo auto-resync : 23:11:2022 - 19:09:11
Diffstat (limited to 'net-misc/seafile/seafile-8.0.9.ebuild')
-rw-r--r--net-misc/seafile/seafile-8.0.9.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/net-misc/seafile/seafile-8.0.9.ebuild b/net-misc/seafile/seafile-8.0.9.ebuild
new file mode 100644
index 000000000000..9cf4647508a0
--- /dev/null
+++ b/net-misc/seafile/seafile-8.0.9.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+# Upstream is moving tags repeatedly, then we use commit hash.
+RELEASE_COMMIT="6bd36a957573eda6a53f3d1bc538dbfc001aa9fd"
+
+inherit autotools python-single-r1 vala
+
+DESCRIPTION="File syncing and sharing software with file encryption and group sharing"
+HOMEPAGE="https://www.seafile.com/ https://github.com/haiwen/seafile/"
+SRC_URI="https://github.com/haiwen/${PN}/archive/${RELEASE_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+-with-openssl-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/future[${PYTHON_USEDEP}]
+ ')
+ dev-libs/openssl:=
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/jansson:=
+ dev-libs/libevent:=
+ net-libs/libsearpc[${PYTHON_SINGLE_USEDEP}]
+ net-misc/curl
+ sys-apps/util-linux
+ sys-libs/zlib
+ elibc_musl? ( sys-libs/fts-standalone )"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
+ $(vala_depend)"
+
+S="${WORKDIR}/${PN}-${RELEASE_COMMIT}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ vala_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ # Remove unnecessary .la files
+ find "${ED}" -name '*.la' -delete || die
+ python_fix_shebang "${ED}"/usr/bin/seaf-cli
+}