summaryrefslogtreecommitdiff
path: root/net-misc/seafile/seafile-6.1.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-14 01:05:40 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-14 01:05:40 +0100
commit76cba73c47c8694e74377004634daca18f2d9c08 (patch)
tree468603ebdc189bcfae77696162761b3be936baea /net-misc/seafile/seafile-6.1.7.ebuild
parent6957f5c65b02bba533954eabc0b62f5de36be206 (diff)
gentoo resync : 14.04.2018
Diffstat (limited to 'net-misc/seafile/seafile-6.1.7.ebuild')
-rw-r--r--net-misc/seafile/seafile-6.1.7.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-misc/seafile/seafile-6.1.7.ebuild b/net-misc/seafile/seafile-6.1.7.ebuild
new file mode 100644
index 000000000000..5e871abceb5b
--- /dev/null
+++ b/net-misc/seafile/seafile-6.1.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+inherit autotools python-single-r1 vala
+
+DESCRIPTION="File syncing and sharing software with file encryption and group sharing"
+HOMEPAGE="https://github.com/haiwen/seafile/ http://www.seafile.com/"
+SRC_URI="https://github.com/haiwen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+-with-openssl-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ net-libs/libsearpc[${PYTHON_USEDEP}]
+ =net-libs/ccnet-${PV}[${PYTHON_USEDEP}]
+ dev-libs/glib:2
+ dev-libs/libevent:0
+ dev-libs/jansson
+ sys-libs/zlib:0
+ net-misc/curl
+ dev-libs/openssl:0
+ dev-db/sqlite:3"
+DEPEND="${RDEPEND}
+ $(vala_depend)"
+
+src_prepare() {
+ default
+ sed -i -e 's/valac /${VALAC} /' lib/Makefile.am || die
+ eautoreconf
+ vala_src_prepare
+}
+
+src_install() {
+ default
+ # Remove unnecessary .la files, as recommended by ltprune.eclass
+ find "${ED}" -name '*.la' -delete || die
+ python_fix_shebang "${ED}"usr/bin
+}