summaryrefslogtreecommitdiff
path: root/net-misc/rsync/rsync-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /net-misc/rsync/rsync-9999.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'net-misc/rsync/rsync-9999.ebuild')
-rw-r--r--net-misc/rsync/rsync-9999.ebuild56
1 files changed, 40 insertions, 16 deletions
diff --git a/net-misc/rsync/rsync-9999.ebuild b/net-misc/rsync/rsync-9999.ebuild
index 0da8ff82f683..d172d6ec7259 100644
--- a/net-misc/rsync/rsync-9999.ebuild
+++ b/net-misc/rsync/rsync-9999.ebuild
@@ -1,32 +1,44 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic prefix systemd
+PYTHON_COMPAT=( python3_{8,9,10} )
+inherit flag-o-matic prefix python-single-r1 systemd
DESCRIPTION="File transfer program to keep remote files into sync"
HOMEPAGE="https://rsync.samba.org/"
-if [[ "${PV}" == *9999 ]] ; then
- PYTHON_COMPAT=( python3_{6,7,8} )
- inherit autotools git-r3 python-any-r1
+if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/WayneD/rsync.git"
+ inherit autotools git-r3
+
+ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
else
- if [[ "${PV}" == *_pre* ]] ; then
+ VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/waynedavison.asc
+ inherit verify-sig
+
+ if [[ ${PV} == *_pre* ]] ; then
SRC_DIR="src-previews"
else
SRC_DIR="src"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
- SRC_URI="https://rsync.samba.org/ftp/rsync/${SRC_DIR}/${P/_/}.tar.gz"
- S="${WORKDIR}/${P/_/}"
+
+ SRC_URI="https://rsync.samba.org/ftp/rsync/${SRC_DIR}/${P/_/}.tar.gz
+ verify-sig? ( https://rsync.samba.org/ftp/rsync/${SRC_DIR}/${P/_/}.tar.gz.asc )"
+ S="${WORKDIR}"/${P/_/}
fi
LICENSE="GPL-3"
SLOT="0"
IUSE="acl examples iconv ipv6 lz4 ssl stunnel system-zlib xattr xxhash zstd"
+REQUIRED_USE+=" examples? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="acl? ( virtual/acl )
+ examples? (
+ ${PYTHON_DEPS}
+ dev-lang/perl
+ )
lz4? ( app-arch/lz4 )
ssl? ( dev-libs/openssl:0= )
system-zlib? ( sys-libs/zlib )
@@ -36,22 +48,29 @@ RDEPEND="acl? ( virtual/acl )
>=dev-libs/popt-1.5
iconv? ( virtual/libiconv )"
DEPEND="${RDEPEND}"
+BDEPEND="examples? ( ${PYTHON_DEPS} )"
-if [[ "${PV}" == *9999 ]] ; then
- BDEPEND="${PYTHON_DEPS}
- $(python_gen_any_dep '
+if [[ ${PV} == *9999 ]] ; then
+ BDEPEND+=" ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
dev-python/commonmark[${PYTHON_USEDEP}]
')"
+else
+ BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-waynedavison )"
fi
-# Only required for live ebuild
-python_check_deps() {
- has_version "dev-python/commonmark[${PYTHON_USEDEP}]"
+pkg_setup() {
+ # - USE=examples needs Python itself at runtime, but nothing else
+ # - 9999 needs commonmark at build time
+ if [[ ${PV} == *9999 ]] || use examples ; then
+ python-single-r1_pkg_setup
+ fi
}
src_prepare() {
default
- if [[ "${PV}" == *9999 ]] ; then
+
+ if [[ ${PV} == *9999 ]] ; then
eaclocal -I m4
eautoconf -o configure.sh
eautoheader && touch config.h.in
@@ -104,14 +123,17 @@ src_install() {
# Install the useful contrib scripts
if use examples ; then
+ python_fix_shebang support/
+
exeinto /usr/share/rsync
doexe support/*
+
rm -f "${ED}"/usr/share/rsync/{Makefile*,*.c}
fi
eprefixify "${ED}"/etc/{,xinetd.d}/rsyncd*
- systemd_newunit "packaging/systemd/rsync.service" "rsyncd.service"
+ systemd_newunit packaging/systemd/rsync.service rsyncd.service
}
pkg_postinst() {
@@ -121,12 +143,14 @@ pkg_postinst() {
ewarn "is a security risk which you should fix. Please check your"
ewarn "/etc/rsyncd.conf file and fix the setting 'use chroot'."
fi
+
if use stunnel ; then
einfo "Please install \">=net-misc/stunnel-4\" in order to use stunnel feature."
einfo
einfo "You maybe have to update the certificates configured in"
einfo "${EROOT}/etc/stunnel/rsync.conf"
fi
+
if use system-zlib ; then
ewarn "Using system-zlib is incompatible with <rsync-3.1.1 when"
ewarn "using the --compress option."