summaryrefslogtreecommitdiff
path: root/net-misc/rclone/rclone-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
commitc5283d322accc6097afec74eab24550829788bab (patch)
treeb99ce668128d82a026eaa31461643f9173f9b77b /net-misc/rclone/rclone-9999.ebuild
parent5510d9d7d1c93c2ea71a2bd6f0666168808d5dd6 (diff)
gentoo resync : 23.03.2018
Diffstat (limited to 'net-misc/rclone/rclone-9999.ebuild')
-rw-r--r--net-misc/rclone/rclone-9999.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/net-misc/rclone/rclone-9999.ebuild b/net-misc/rclone/rclone-9999.ebuild
index 0c936bdca50e..2c530609ee7b 100644
--- a/net-misc/rclone/rclone-9999.ebuild
+++ b/net-misc/rclone/rclone-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit golang-build
+inherit golang-build bash-completion-r1
EGO_PN="github.com/ncw/${PN}"
if [[ ${PV} == *9999* ]]; then
@@ -28,4 +28,11 @@ src_install() {
dobin ${PN}
doman src/${EGO_PN}/${PN}.1
dodoc src/${EGO_PN}/README.md
+
+ ./rclone genautocomplete bash ${PN}.bash || die
+ newbashcomp ${PN}.bash ${PN}
+
+ ./rclone genautocomplete zsh ${PN}.zsh || die
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
}