summaryrefslogtreecommitdiff
path: root/net-misc/r8168/r8168-8.047.05.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /net-misc/r8168/r8168-8.047.05.ebuild
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'net-misc/r8168/r8168-8.047.05.ebuild')
-rw-r--r--net-misc/r8168/r8168-8.047.05.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/r8168/r8168-8.047.05.ebuild b/net-misc/r8168/r8168-8.047.05.ebuild
new file mode 100644
index 000000000000..5d05429e616c
--- /dev/null
+++ b/net-misc/r8168/r8168-8.047.05.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info linux-mod eutils
+
+DESCRIPTION="r8168 driver for Realtek 8111/8168 PCI-E NICs"
+HOMEPAGE="https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software"
+SRC_URI="${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="fetch"
+
+MODULE_NAMES="r8168(net:${S}/src)"
+BUILD_TARGETS="modules"
+
+CONFIG_CHECK="!R8169"
+ERROR_R8169="${P} requires Realtek 8169 PCI Gigabit Ethernet adapter (CONFIG_R8169) to be DISABLED"
+
+pkg_nofetch() {
+ einfo "Please download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "using the \"GBE Ethernet LINUX driver r8168 for kernel up to 4.15\" link."
+}
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELDIR=${KV_DIR}"
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc README
+}