summaryrefslogtreecommitdiff
path: root/net-misc/pyhoca-gui/pyhoca-gui-0.6.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /net-misc/pyhoca-gui/pyhoca-gui-0.6.1.1.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'net-misc/pyhoca-gui/pyhoca-gui-0.6.1.1.ebuild')
-rw-r--r--net-misc/pyhoca-gui/pyhoca-gui-0.6.1.1.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/net-misc/pyhoca-gui/pyhoca-gui-0.6.1.1.ebuild b/net-misc/pyhoca-gui/pyhoca-gui-0.6.1.1.ebuild
index 3d05ef2fc367..671e506e1ffe 100644
--- a/net-misc/pyhoca-gui/pyhoca-gui-0.6.1.1.ebuild
+++ b/net-misc/pyhoca-gui/pyhoca-gui-0.6.1.1.ebuild
@@ -1,27 +1,32 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_7 )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="X2Go graphical client applet"
HOMEPAGE="http://www.x2go.org"
SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
-LICENSE="AGPL-3"
+LICENSE="AGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND="dev-python/pycups[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-python/pycups[${PYTHON_USEDEP}]
dev-python/setproctitle[${PYTHON_USEDEP}]
dev-python/wxpython[${PYTHON_USEDEP}]
>=net-misc/python-x2go-0.6.1.1[${PYTHON_USEDEP}]
x11-libs/libnotify"
-DEPEND="${DEPEND}
- dev-python/python-distutils-extra[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/python-distutils-extra[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # we don't need setuptools at runtime
+ sed -i -e '/install_requires/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
python_install() {
distutils-r1_python_install