summaryrefslogtreecommitdiff
path: root/net-misc/pyhoca-gui/pyhoca-gui-0.6.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /net-misc/pyhoca-gui/pyhoca-gui-0.6.1.1.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'net-misc/pyhoca-gui/pyhoca-gui-0.6.1.1.ebuild')
-rw-r--r--net-misc/pyhoca-gui/pyhoca-gui-0.6.1.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/pyhoca-gui/pyhoca-gui-0.6.1.1.ebuild b/net-misc/pyhoca-gui/pyhoca-gui-0.6.1.1.ebuild
new file mode 100644
index 000000000000..45f64acd9e49
--- /dev/null
+++ b/net-misc/pyhoca-gui/pyhoca-gui-0.6.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="X2Go graphical client applet"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pycups[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ dev-python/wxpython[${PYTHON_USEDEP}]
+ >=net-misc/python-x2go-0.6.1.1[${PYTHON_USEDEP}]
+ x11-libs/libnotify"
+DEPEND="${DEPEND}
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]"
+
+python_install() {
+ distutils-r1_python_install
+ python_doscript ${PN}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/man1/*
+ find "${ED}" -name '*.pth' -delete || die
+}