summaryrefslogtreecommitdiff
path: root/net-misc/putty/putty-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-10 13:27:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-10 13:27:24 +0100
commit0d7aefa5885e7552b4c2221df9f54e5930696228 (patch)
treeb7f05f240bfd3bc81f87edba206e78a8dc1a664b /net-misc/putty/putty-9999.ebuild
parent34d9839f7e484ac761071da50298470aa5ef5123 (diff)
gentoo auto-resync : 10:07:2022 - 13:27:24
Diffstat (limited to 'net-misc/putty/putty-9999.ebuild')
-rw-r--r--net-misc/putty/putty-9999.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/net-misc/putty/putty-9999.ebuild b/net-misc/putty/putty-9999.ebuild
index a09ae7ae4600..be3a4064accf 100644
--- a/net-misc/putty/putty-9999.ebuild
+++ b/net-misc/putty/putty-9999.ebuild
@@ -6,7 +6,7 @@ inherit cmake desktop xdg-utils
DESCRIPTION="A Free Telnet/SSH Client"
HOMEPAGE="https://www.chiark.greenend.org.uk/~sgtatham/putty/"
-SRC_URI="https://dev.gentoo.org/~polynomial-c/${PN}-icons.tar.bz2"
+SRC_URI="https://dev.gentoo.org/~matthew/distfiles/${PN}-icons.tar.bz2"
if [[ ${PV} == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://git.tartarus.org/simon/putty.git"
@@ -17,7 +17,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="debug +gtk gtk2 ipv6 gssapi"
+IUSE="debug doc +gtk gtk2 ipv6 gssapi"
RDEPEND="
!net-misc/pssh
@@ -37,8 +37,8 @@ DEPEND="
BDEPEND="
dev-lang/perl
virtual/pkgconfig
+ doc? ( app-doc/halibut )
"
-#[[ ${PV} == *9999 ]] && BDEPEND+=" doc? ( app-doc/halibut )"
REQUIRED_USE="
gtk2? ( gtk )
@@ -60,15 +60,19 @@ src_configure() {
cmake_src_configure
}
+src_compile() {
+ cmake_src_compile all doc
+}
+
src_install() {
cmake_src_install
doman "${BUILD_DIR}"/doc/*.1
- #if use doc ; then
- # docinto html
- # dodoc "${BUILD_DIR}"/doc/html/*.html
- #fi
+ if use doc ; then
+ docinto html
+ dodoc "${BUILD_DIR}"/doc/html/*.html
+ fi
if use gtk ; then
local i