summaryrefslogtreecommitdiff
path: root/net-misc/pipes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-22 14:25:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-22 14:25:03 +0100
commit5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (patch)
treeb041acef19bb9ae66c228d5c9d34d1e00aeb2b95 /net-misc/pipes
parent5cfef3c94cd7e82136c69a0322f5ba21f7e64632 (diff)
gentoo resync : 22.04.2018
Diffstat (limited to 'net-misc/pipes')
-rw-r--r--net-misc/pipes/Manifest4
-rw-r--r--net-misc/pipes/files/pipes-1.16.1-execlp.patch14
-rw-r--r--net-misc/pipes/metadata.xml14
-rw-r--r--net-misc/pipes/pipes-1.16.1-r1.ebuild29
4 files changed, 53 insertions, 8 deletions
diff --git a/net-misc/pipes/Manifest b/net-misc/pipes/Manifest
index 5ba288ee57d0..3a3595ce9463 100644
--- a/net-misc/pipes/Manifest
+++ b/net-misc/pipes/Manifest
@@ -1,3 +1,5 @@
+AUX pipes-1.16.1-execlp.patch 603 BLAKE2B fb36b8f00c05b8f0fef930757da458d1f571ecda4487cf5641417d9a79548e28212c1a12599b69a068d55a2e5cb991de0c37b787e13516965122e949bac5db40 SHA512 ad28dab392c962fc476ca6596a0609dbee2a3f6300b27daaaae5b5e44c3c94154b682bc749697be20373b530b228d45170193e085e96bbcbfeff7190746767d7
DIST pipes-1.16.1.tar.bz2 21642 BLAKE2B c5725244f7ac0b77ff3ac3d753ff96ac7d853cd1e7cb0ab82a14decc6ad6ec94503426be712e1b9117a6e95a95939c5d9e91d9f31eb397c96182fac8f7148100 SHA512 ff8f6cf7934149c3d8a6e0443a06840863313acccd31791913fa25b086173e834d8f357212811e5e1ddb62148d3e687858e8956065734f11d7fc729f2a64b0a3
+EBUILD pipes-1.16.1-r1.ebuild 655 BLAKE2B 57c0bdf1fdf4fd7b9ee871d0cda6af5ebc8e985b8658a1ff8167482d618884ee7dcd008d158f665b0c2123f46100242df67abc0450aa5411f4f45e75ed6bd22e SHA512 be0218f5426382ba7ac4aab51361fdb8670de2638e0dc99b50e6d8f955d2fd8eed00be4e0fcb27b1accab661f174155821995f0859ff5438cb53aafa077555c5
EBUILD pipes-1.16.1.ebuild 649 BLAKE2B 3444b2bb041d4f8384f0416839352f1ada2936ff73cc8085756f7e241bd46c38a3074d622ffc37f97a492740b72aedb69c4199268cfa1b4dc22d03ae54bd21ac SHA512 1e8aa77ed31a3d7028e57825eee3853c5bfd40e8bd497219f68366574a78fa5c1b9eba34764d957ba370e17f23f0f29dff8aa68e0c28307257dadfd26a30c3d1
-MISC metadata.xml 1243 BLAKE2B 7223666ce1373a93c0a289eda47d2ccb5d8aa16a4aa954bdccbddb6ff0e32ef1f1762e764a5f83bfc1f7a2b921202ed0230dcfe67b569bf6ce0f5b8227cc6eac SHA512 bae97cf81ba152b00707b1737908c5a60cef1cae95d2b9c8dcac814a74f6bf587471be8c6bdfa4688d74651c6df53777cfea72ee318b6cefe1ecc36c19e76734
+MISC metadata.xml 1243 BLAKE2B 018079999961b4720d9f6999852b0c6d90ed32d08ac9a2084659d35ccccfd9db602a5ea6540928e1dbf0f942ea06f9cc9358231a0d041eea5aa8620f6a61079b SHA512 64f85cdfbd01bc948cc78a5b0a7816d45583c861cc45144ff0b4547b704516a5151d18b19a99be58ad666f3dcbcd866c215e5a24c237c7b97a35e689841316e0
diff --git a/net-misc/pipes/files/pipes-1.16.1-execlp.patch b/net-misc/pipes/files/pipes-1.16.1-execlp.patch
new file mode 100644
index 000000000000..d7e31cced8c8
--- /dev/null
+++ b/net-misc/pipes/files/pipes-1.16.1-execlp.patch
@@ -0,0 +1,14 @@
+--- a/plis.c
++++ b/plis.c
+@@ -443,9 +443,9 @@
+ if(!strncmp(argv[a], "pcon ", 5)) ChildPconTest(argv[a]);
+
+ if(usesh)
+- execl(SHELL, "sh", "-c", argv[a], NULL);
++ execl(SHELL, "sh", "-c", argv[a], (char *) NULL);
+ else
+- execlp(argv[a], NULL);
++ execlp(argv[a], ";", (char *) NULL);
+ }
+ else
+ {
diff --git a/net-misc/pipes/metadata.xml b/net-misc/pipes/metadata.xml
index abddd073acfe..55a569831fb9 100644
--- a/net-misc/pipes/metadata.xml
+++ b/net-misc/pipes/metadata.xml
@@ -8,13 +8,13 @@
<longdescription>
I just noticed that netpipes doesn't support bidirectional pipes.
So I made my own version.
-Now I can say in computer A that "plis 12345 -io ohjelma" and in computer B that "pcon A 12345 -io ohjelma2",
-and they communicate together then.
-My example utilization was that I can send the picture of SNES-emulator to another
-computer via network, and grab the keyboard input there, so get two consoles to
-the same game.
-My friend wanted to watch when I play FF6, but didn't want to sit next to my monitor,
-and asked if he could get the picture to his monitor.
+Now I can say in computer A that "plis 12345 -io ohjelma" and in computer B
+that "pcon A 12345 -io ohjelma2", and they communicate together then.
+My example utilization was that I can send the picture of SNES-emulator to
+another computer via network, and grab the keyboard input there, so get two
+consoles to the same game.
+My friend wanted to watch when I play FF6, but didn't want to sit next to my
+monitor, and asked if he could get the picture to his monitor.
And he got it.
Then he asked if he could play it from his computer at the same time as me...
And now it works too.
diff --git a/net-misc/pipes/pipes-1.16.1-r1.ebuild b/net-misc/pipes/pipes-1.16.1-r1.ebuild
new file mode 100644
index 000000000000..7d8cc7dd125f
--- /dev/null
+++ b/net-misc/pipes/pipes-1.16.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Very versatile TCP pipes"
+HOMEPAGE="http://bisqwit.iki.fi/source/pipes.html"
+SRC_URI="http://bisqwit.iki.fi/src/arch/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~s390 ~x86"
+PATCHES=(
+ "${FILESDIR}"/${P}-execlp.patch
+)
+
+src_compile() {
+ # Prevent the build system from looking for dependencies
+ touch .depend || die
+
+ emake CC=$(tc-getCC) OPTIM="${CFLAGS}" LDFLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dobin plis
+ dosym plis /usr/bin/pcon
+ dodoc ChangeLog Examples README.html
+}