summaryrefslogtreecommitdiff
path: root/net-misc/pedro/pedro-1.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /net-misc/pedro/pedro-1.6-r1.ebuild
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'net-misc/pedro/pedro-1.6-r1.ebuild')
-rw-r--r--net-misc/pedro/pedro-1.6-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-misc/pedro/pedro-1.6-r1.ebuild b/net-misc/pedro/pedro-1.6-r1.ebuild
new file mode 100644
index 000000000000..0d2ffbd916f8
--- /dev/null
+++ b/net-misc/pedro/pedro-1.6-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Pedro is a subscription/notification communications system"
+HOMEPAGE="https://staff.itee.uq.edu.au/pjr/HomePages/PedroHome.html"
+SRC_URI="https://staff.itee.uq.edu.au/pjr/HomePages/PedroFiles/${P}.tgz
+ doc? ( mirror://gentoo/${PN}-manual-${PV}.tar.gz )"
+S="${WORKDIR}"/${P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc examples"
+
+RDEPEND="dev-libs/glib:2"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-portage.patch
+)
+
+src_configure() {
+ tc-export PKG_CONFIG
+
+ default
+}
+
+src_install() {
+ default
+
+ if use doc ; then
+ dodoc "${WORKDIR}"/${PN}.pdf
+ fi
+
+ if use examples ; then
+ docinto examples
+ dodoc src/examples/*.{c,tcl}
+
+ docinto examples/java_api
+ dodoc src/java_api/*.java
+
+ docinto examples/python_api
+ dodoc src/python_api/*.py
+ fi
+}