summaryrefslogtreecommitdiff
path: root/net-misc/passt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-13 11:40:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-13 11:40:30 +0000
commit0ded23e9afc3d3424aef90e5cec3f2ca6d6b4c30 (patch)
tree93ef9828fae35063d273f386b2fa4a7130add56b /net-misc/passt
parent22b4e2ee9c8011b75d7c030d6129a7487494aeba (diff)
gentoo auto-resync : 13:12:2023 - 11:40:30
Diffstat (limited to 'net-misc/passt')
-rw-r--r--net-misc/passt/Manifest4
-rw-r--r--net-misc/passt/metadata.xml23
-rw-r--r--net-misc/passt/passt-2023.12.04.ebuild29
-rw-r--r--net-misc/passt/passt-9999.ebuild29
4 files changed, 85 insertions, 0 deletions
diff --git a/net-misc/passt/Manifest b/net-misc/passt/Manifest
new file mode 100644
index 000000000000..cfbecd681819
--- /dev/null
+++ b/net-misc/passt/Manifest
@@ -0,0 +1,4 @@
+DIST passt-2023.12.04.tar.xz 188136 BLAKE2B f1d72fbb4bbb25f6a11e9ff87a91cf9bac06e047b8cb9a8b40402ced1422c23b105fa7e64646698d38ad747efa449c34cfdaecf492a3e4984114cbcf60656cdc SHA512 febd9fa22363438b52b2688481183d81c22966e1775139fc559dbfa50437c9b00ba09800db867738d25fcea8ac05d4589b75dcd2d0c88eeffefc0598d4236001
+EBUILD passt-2023.12.04.ebuild 707 BLAKE2B fe3b6c4c697e725c51b3cefec18e7501055c3abb0d2cb74d8b5983a73a6803ff2a5fafa2502b54725e4225072a5fa2dc6e0043524c89c6019d5380df79314aeb SHA512 0845a4d1dda79af28f08b2735297cd8fc515460df24fa9cf8d5d8653ffa3c20379e3ab5167b895fcd35b7f2068531aebe7c2e51fe9b86a65aa526f9a2cbf3306
+EBUILD passt-9999.ebuild 707 BLAKE2B fe3b6c4c697e725c51b3cefec18e7501055c3abb0d2cb74d8b5983a73a6803ff2a5fafa2502b54725e4225072a5fa2dc6e0043524c89c6019d5380df79314aeb SHA512 0845a4d1dda79af28f08b2735297cd8fc515460df24fa9cf8d5d8653ffa3c20379e3ab5167b895fcd35b7f2068531aebe7c2e51fe9b86a65aa526f9a2cbf3306
+MISC metadata.xml 1301 BLAKE2B ea587b72b8f9967736c28bac8993cb8810d6a859a4517df795aa494ae913eec6de9f377404c05aa03f401aa3421191f3d88659bf5a0aef8a5d7a96fcf63764ad SHA512 1ff3fa75592548a6d71c9037a186bf62e56ab672158bacc19a4d652251671e395f5fca550610688e0a6dec4c595be87cc22db680d2a0702893a90af8c6cf7020
diff --git a/net-misc/passt/metadata.xml b/net-misc/passt/metadata.xml
new file mode 100644
index 000000000000..142a4c26b564
--- /dev/null
+++ b/net-misc/passt/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>me@rahil.website</email>
+ <name>Rahil Bhimjiani</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ passt implements a translation layer between a Layer-2 network interface and native Layer-4 sockets (TCP, UDP, ICMP/ICMPv6 echo) on a host. It doesn't require any capabilities or privileges, and it can be used as a simple replacement for Slirp.
+
+ pasta (same binary as passt, different command) offers equivalent functionality, for network namespaces: traffic is forwarded using a tap interface inside the namespace, without the need to create further interfaces on the host, hence not requiring any capabilities or privileges.
+
+ qrap is a wrapper, designed specifically for usage with qemu(1) and passt(1), connecting a UNIX domain socket to a file descriptor, and running qemu(1) with given arguments.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://passt.top/passt/bugs</bugs-to>
+ <doc>https://passt.top/passt/about/</doc>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/passt/passt-2023.12.04.ebuild b/net-misc/passt/passt-2023.12.04.ebuild
new file mode 100644
index 000000000000..5683bd6f8693
--- /dev/null
+++ b/net-misc/passt/passt-2023.12.04.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="User-mode networking daemons for VMs and namespaces, replacement for Slirp"
+HOMEPAGE="https://passt.top/"
+
+RELEASE_COMMIT="b86afe3"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://passt.top/passt"
+else
+ SRC_URI="https://passt.top/passt/snapshot/passt-${RELEASE_COMMIT}.tar.xz -> ${P}.tar.xz"
+ S="${WORKDIR}/${PN}-${RELEASE_COMMIT}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+IUSE="static"
+
+src_compile() {
+ [[ ${PV} != 9999* ]] && export VERSION="${PV}"
+ export prefix="${EPREFIX}/usr" docdir="${EPREFIX}/usr/share/doc/${P}"
+
+ emake $(usev static)
+}
diff --git a/net-misc/passt/passt-9999.ebuild b/net-misc/passt/passt-9999.ebuild
new file mode 100644
index 000000000000..5683bd6f8693
--- /dev/null
+++ b/net-misc/passt/passt-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="User-mode networking daemons for VMs and namespaces, replacement for Slirp"
+HOMEPAGE="https://passt.top/"
+
+RELEASE_COMMIT="b86afe3"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://passt.top/passt"
+else
+ SRC_URI="https://passt.top/passt/snapshot/passt-${RELEASE_COMMIT}.tar.xz -> ${P}.tar.xz"
+ S="${WORKDIR}/${PN}-${RELEASE_COMMIT}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+IUSE="static"
+
+src_compile() {
+ [[ ${PV} != 9999* ]] && export VERSION="${PV}"
+ export prefix="${EPREFIX}/usr" docdir="${EPREFIX}/usr/share/doc/${P}"
+
+ emake $(usev static)
+}