summaryrefslogtreecommitdiff
path: root/net-misc/openvswitch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /net-misc/openvswitch
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'net-misc/openvswitch')
-rw-r--r--net-misc/openvswitch/Manifest2
-rw-r--r--net-misc/openvswitch/openvswitch-2.15.0.ebuild144
2 files changed, 146 insertions, 0 deletions
diff --git a/net-misc/openvswitch/Manifest b/net-misc/openvswitch/Manifest
index 15bc0487b530..282bc5bf0d99 100644
--- a/net-misc/openvswitch/Manifest
+++ b/net-misc/openvswitch/Manifest
@@ -11,5 +11,7 @@ AUX ovsdb-server_conf 492 BLAKE2B e82cd92a1ac46023d63a70093e0f9cf78b72eed20a70d2
AUX ovsdb-server_conf2 584 BLAKE2B ac54fe7f3b593dce07f051874e4ebc59ab2872fcc994e55464f8ab74135498613f9a3bb38366babeae909ae8179be87c1168a069f427d4310f220afbb58d12da SHA512 0878963eef09a3933fcdb66e7ce1ab66131ce3ee1af5d403456e0f44d763e96ff90460d9013cea9a3eb0630d60a6b8aed04aeee6789882842975df2e86bc0b9e
AUX xcp-interface-reconfigure-2.3.2.patch 920 BLAKE2B a0cf230e9793484309ec38a6faf7ba386ae4e1ba7b8c77e3a3f0cbdef63d128dd765362e4ab8077da04a60444718283cc68d0a402ed12fa168c2ca983c1064a6 SHA512 7f2dd6fbd3f734abe2cf8e23a0aa49d81a8acb26ac5c28004a95ec0fe4630f7792aabdaeb8825a62ff96fcf1c3a871eea10b11c6b92ddf7965aa1f73150f7ec7
DIST openvswitch-2.14.1.tar.gz 7388751 BLAKE2B 5f73dfc76101724564b1e8a1a79a13775e0394bcd97690b4e6ab860db5f639c636573d70927d257c6f8cd80b5b1780f909ad0521b842069bc6c6e069696bc416 SHA512 1dfc119fc230ea7bc2569544d24409b624593f16eea8d7034e0fced8ccfa09b0cde65244f9032bbad30885feada12c28065b776eadef85fc714743139ce7ff0b
+DIST openvswitch-2.15.0.tar.gz 7434380 BLAKE2B c2f855ece89da3277f090d4328ff1659cc4976a4dbdfa44bdd4e750ea80e72592536af00250abe25565a6c2cda9f086ca22dcc16ed9db38692028a758995e9ac SHA512 a4e49268d6dd7d9d8fbf2005e8ffe45ede0998d21c98d7018474142656c65c05b14c8a7e4c7d8e0eea36e28d87550826225205e1fa03055d35a8cb048617c832
EBUILD openvswitch-2.14.1.ebuild 4412 BLAKE2B 349b7cae8d88f157b608189086b111d5ad0af227cc15a7dce04cfb94874e19551851fd09f12c414f2884294f86a6371bf956b37d9161072c5f612ebad7a557bc SHA512 35f1ddd7393bf0a57132ef1a7f3d2c872a057eb95f33dd7bc1703147c73675a4797b9b87d6fd0314e1f75cae29282e1305b91cb0a58d4862ccea2dc1ae5db349
+EBUILD openvswitch-2.15.0.ebuild 4370 BLAKE2B 7587be9823c2db3e0f7c815de8a226904b6c67fc2fe7edd1b7071e97906a10c89dc163f0a53771f88c51f6fd081a4e7203027a9434e9f0042eaafbc20d850394 SHA512 973d59ef1d51d4550bb671f607eda6b4737ba881dae26228c708f1e5769f443b44890acca2ea997014e80ad9dd67dbe8f293c401d64ab8880d9bbfb4e3c51c62
MISC metadata.xml 458 BLAKE2B 52809b1a9ff6c0e69988e6e17cfe34145abcbe45c9d08e94f7fcc79e4ef72aeeaf2485349a04e16190c25c5b5cd61848253f5f63f1a50bf10e63918cae2ee1fa SHA512 080e0b3bbdc520573998377b41b08ca9ef0b049affb093fd98cc8af1d33c3c18a341a158ab3cf426a15641671018abf9f4a20734508276bbc88882b9f27eec36
diff --git a/net-misc/openvswitch/openvswitch-2.15.0.ebuild b/net-misc/openvswitch/openvswitch-2.15.0.ebuild
new file mode 100644
index 000000000000..7f44d4ded567
--- /dev/null
+++ b/net-misc/openvswitch/openvswitch-2.15.0.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_7 python3_8 python3_9 )
+
+inherit autotools linux-info linux-mod python-r1 systemd tmpfiles
+
+DESCRIPTION="Production quality, multilayer virtual switch"
+HOMEPAGE="https://www.openvswitch.org"
+SRC_URI="https://www.openvswitch.org/releases/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="debug modules monitor +ssl"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ssl? ( dev-libs/openssl:0= )
+ ${PYTHON_DEPS}
+ ~dev-python/ovs-2.13.3[${PYTHON_USEDEP}]
+ dev-python/twisted[conch,${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ debug? ( dev-lang/perl )"
+DEPEND="${RDEPEND}
+ sys-apps/util-linux[caps]"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES="
+ "${FILESDIR}/xcp-interface-reconfigure-2.3.2.patch"
+"
+
+CONFIG_CHECK="~NET_CLS_ACT ~NET_CLS_U32 ~NET_SCH_INGRESS ~NET_ACT_POLICE ~IPV6 ~TUN"
+MODULE_NAMES="openvswitch(net:${S}/datapath/linux)"
+BUILD_TARGETS="all"
+
+pkg_setup() {
+ if use modules ; then
+ CONFIG_CHECK+=" ~!OPENVSWITCH"
+ kernel_is ge 3 10 0 || die "Linux >= 3.10.0 and <= 5.8 required for userspace modules"
+ kernel_is le 5 8 999 || die "Linux >= 3.10.0 and <= 5.8 required for userspace modules"
+ linux-mod_pkg_setup
+ else
+ CONFIG_CHECK+=" ~OPENVSWITCH"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # Never build kernelmodules, doing this manually
+ sed -i \
+ -e '/^SUBDIRS/d' \
+ datapath/Makefile.in || die "sed failed"
+ eautoreconf
+ default
+}
+
+src_configure() {
+ set_arch_to_kernel
+ # monitor is statically enabled for bug 596206
+ # use monitor || export ovs_cv_python="no"
+ # pyside is staticly disabled
+ export ovs_cv_pyuic4="no"
+
+ # flake8 is primarily a style guide tool, running it as part of the tests
+ # in Gentoo does not make much sense, only breaks them: bug 607280
+ export ovs_cv_flake8="no"
+
+ local linux_config
+ use modules && linux_config="--with-linux=${KV_OUT_DIR}"
+
+ econf ${linux_config} \
+ --with-rundir=/var/run/openvswitch \
+ --with-logdir=/var/log/openvswitch \
+ --with-pkidir=/etc/ssl/openvswitch \
+ --with-dbdir=/var/lib/openvswitch \
+ $(use_enable ssl) \
+ $(use_enable !debug ndebug)
+}
+
+src_compile() {
+ default
+
+ use modules && linux-mod_src_compile
+}
+
+src_install() {
+ default
+
+ local SCRIPT
+ if use monitor; then
+ for SCRIPT in ovs-{pcap,parse-backtrace,dpctl-top,l3ping,tcpdump,tcpundump,test,vlan-test} bugtool/ovs-bugtool; do
+ sed -e '1s|^.*$|#!/usr/bin/python|' -i utilities/"${SCRIPT}"
+ python_foreach_impl python_doscript utilities/"${SCRIPT}"
+ done
+ rm -r "${ED}"/usr/share/openvswitch/python || die
+ fi
+
+ keepdir /var/{lib,log}/openvswitch
+ keepdir /etc/ssl/openvswitch
+ fperms 0750 /etc/ssl/openvswitch
+
+ rm -rf "${ED}"/var/run || die
+
+ newconfd "${FILESDIR}/ovsdb-server_conf2" ovsdb-server
+ newconfd "${FILESDIR}/ovs-vswitchd.confd-r2" ovs-vswitchd
+ newinitd "${FILESDIR}/ovsdb-server-r1" ovsdb-server
+ newinitd "${FILESDIR}/ovs-vswitchd-r1" ovs-vswitchd
+
+ systemd_newunit "${FILESDIR}/ovsdb-server-r3.service" ovsdb-server.service
+ systemd_newunit "${FILESDIR}/ovs-vswitchd-r3.service" ovs-vswitchd.service
+ systemd_newunit rhel/usr_lib_systemd_system_ovs-delete-transient-ports.service ovs-delete-transient-ports.service
+ newtmpfiles "${FILESDIR}/openvswitch.tmpfiles" openvswitch.conf
+
+ insinto /etc/logrotate.d
+ newins rhel/etc_logrotate.d_openvswitch openvswitch
+
+ use modules && linux-mod_src_install
+}
+
+pkg_postinst() {
+ use modules && linux-mod_pkg_postinst
+
+ # only needed on non-systemd, but helps anyway
+ elog "Use the following command to create an initial database for ovsdb-server:"
+ elog " emerge --config =${CATEGORY}/${PF}"
+ elog "(will create a database in /var/lib/openvswitch/conf.db)"
+ elog "or to convert the database to the current schema after upgrading."
+}
+
+pkg_config() {
+ local db="${EROOT%}"/var/lib/openvswitch/conf.db
+ if [[ -e "${db}" ]] ; then
+ einfo "Database '${db}' already exists, doing schema migration..."
+ einfo "(if the migration fails, make sure that ovsdb-server is not running)"
+ ovsdb-tool convert "${db}" \
+ "${EROOT}"/usr/share/openvswitch/vswitch.ovsschema || die "converting database failed"
+ else
+ einfo "Creating new database '${db}'..."
+ ovsdb-tool create "${db}" \
+ "${EROOT}"/usr/share/openvswitch/vswitch.ovsschema || die "creating database failed"
+ fi
+}