summaryrefslogtreecommitdiff
path: root/net-misc/omniORB
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /net-misc/omniORB
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'net-misc/omniORB')
-rw-r--r--net-misc/omniORB/Manifest2
-rw-r--r--net-misc/omniORB/omniORB-4.2.4.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/net-misc/omniORB/Manifest b/net-misc/omniORB/Manifest
index 61a10f8de35c..1b096570e919 100644
--- a/net-misc/omniORB/Manifest
+++ b/net-misc/omniORB/Manifest
@@ -1,4 +1,6 @@
AUX omniNames 571 BLAKE2B d1a151abb6faf582478e3892b7b057f92263fa0278cb3f3fb82fec20ba60b3e40733fcc2b223286466c9f4eb60fbe49cd9ce239f95e7e1cccb5b5b1df2e88893 SHA512 98f08cd0bef699bdd8da026efbf211c5bf8dfa5bb24bd4438581dd4acf6cbabdb42e19de5a5d8ae9db74bafea86fb316ff75f3278c255cab7277f95681578044
DIST omniORB-4.2.2.tar.bz2 2673800 BLAKE2B 6afe4759cf19b69bd02d4864e305a0ebd0d11943a54c20d53987d9775f04833d5d2dbeb99e5bdcc59d56f116cfb14b9ae92399323e3980a44d9cef47a012c24f SHA512 3fe6c05d0e7f19455c4cd6702887f91b7d14cdc248008cbc456c103072a37251387877bd64d59a271c6e92703a70bbbb9713f9fa2e45d094628e42564cffd0ad
+DIST omniORB-4.2.4.tar.bz2 2713397 BLAKE2B 5759b2563dca421b9a994bb13c30ce6dd98324a2357c4908130a42ce5baec357b881c22b4dff27809607ebde27e7cd65305a91aa5cbdb6d68a19df1f36524e72 SHA512 0b142b127175f16f844823e5adf5593b290528646e13a4c30f6cbd92d159d3998a81b952717039c3f0e386f79404ddd18a3de35fc45fa88383d1d9e51064d988
EBUILD omniORB-4.2.2.ebuild 2356 BLAKE2B 399814240e5c0b85626ffb6800812207be3d7a3929d2defb4fc7a0f857d9d3f0187eb6986602696f636d30dcc527a85f7d51a985cef437196eb238ddfc750919 SHA512 f1019973a9c3feab9b118df4f9dd76cc028e995e5ec488f7b2d9822cf030ab1a9cb8c5ecd2779a3595cf2e4b3d5772653f95e18bdd11406c0a474a3e8460aaae
+EBUILD omniORB-4.2.4.ebuild 2360 BLAKE2B 125f9d6421b3a5f2b985a39d8005027c6f056296f380008215a69e725e883f45bae8dd69ed56a764263b75c994973a9b8404653231569651b5ffb121c8ef6a2c SHA512 fefb14322b1a452eab1bde9fdb3f6a5a1f637f57064381e1ef7268f4620e1b4fde60ea5d08bd13d09355e8a29b3dd2166d4262942212e3bfe81758bac03147c6
MISC metadata.xml 247 BLAKE2B c2c840442760456aa29eeda2b225baa3eca5af75444074a09d500b1063f59ce978b5053c0d79fb7cd3717a477ef8e8e343dcf731a5a99e27058b0528c5066a4f SHA512 d76af24fd2513c0ed4a1f3066c9e9b9eb6407d1c013f22b3bcc9646fb771560c45c42c3851075ce9aa32bfe6ef68534cf1ccd3fefc9657fdb0b2794424ab8d1f
diff --git a/net-misc/omniORB/omniORB-4.2.4.ebuild b/net-misc/omniORB/omniORB-4.2.4.ebuild
new file mode 100644
index 000000000000..3c0e6d3f124b
--- /dev/null
+++ b/net-misc/omniORB/omniORB-4.2.4.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit python-single-r1
+
+MY_P="${P/_p/-}"
+DESCRIPTION="A robust, high-performance CORBA 2 ORB"
+HOMEPAGE="http://omniorb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/omniorb/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc ipv6 ssl"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # The OPTC(XX)FLAGS variables aren't present in these files, but we
+ # will set them when we call emake.
+ sed \
+ -e 's/^CXXDEBUGFLAGS.*/CXXDEBUGFLAGS = $(OPTCXXFLAGS)/' \
+ -e 's/^CDEBUGFLAGS.*/CDEBUGFLAGS = $(OPTCFLAGS)/' \
+ -i mk/beforeauto.mk.in mk/platforms/i586_linux_2.0*.mk || \
+ die "failed to switch CFLAGS variables in the makefile includes"
+
+ # The out-of-source build is suggested by upstream.
+ mkdir build || die "failed to create build directory"
+}
+
+src_configure() {
+ cd build || die "failed to change into the build directory"
+
+ ECONF_SOURCE=".." econf \
+ --disable-static \
+ --with-omniORB-config=/etc/omniorb/omniORB.cfg \
+ --with-omniNames-logdir=/var/log/omniORB \
+ --libdir="/usr/$(get_libdir)" \
+ $(use_enable ipv6) \
+ $(use_with ssl openssl "/usr")
+}
+
+src_compile() {
+ cd build || die "failed to change into the build directory"
+ emake OPTCFLAGS="${CFLAGS}" OPTCXXFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ cd build || die "failed to change into the build directory"
+ default
+
+ rm "${ED}/usr/bin/omniidlrun.py" || \
+ die "failed to remove redundant omniidlrun.py"
+
+ cd "${S}" || die "failed to change into the ${S} directory"
+
+ dodoc CREDITS doc/*.html ReleaseNotes.txt update.log
+ dodoc -r doc/omniORB
+
+ if use doc; then
+ dodoc doc/*.pdf
+ fi
+
+ cat <<- EOF > "${T}/90omniORB"
+ PATH="/usr/share/omniORB/bin/scripts"
+ OMNIORB_CONFIG="/etc/omniorb/omniORB.cfg"
+ EOF
+ doenvd "${T}/90omniORB"
+ doinitd "${FILESDIR}"/omniNames
+
+ cp "sample.cfg" "${T}/omniORB.cfg" || die
+ cat <<- EOF >> "${T}/omniORB.cfg"
+ # resolve the omniNames running on localhost
+ InitRef = NameService=corbaname::localhost
+ EOF
+ insinto /etc/omniorb
+ doins "${T}"/omniORB.cfg
+
+ keepdir /var/log/omniORB
+
+ python_optimize
+ python_fix_shebang "${ED}"/usr/bin/omniidl
+}