summaryrefslogtreecommitdiff
path: root/net-misc/nyx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-22 14:28:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-22 14:28:15 +0000
commitaae71b4d8e684ca22d28ef0f1da0989e7bf6468d (patch)
tree0e9cf35d85726e6aa9fbd58b12035f92ffec0130 /net-misc/nyx
parent20ed81714fa97f5845db16a3c142b3b44d820bc4 (diff)
gentoo auto-resync : 22:02:2023 - 14:28:15
Diffstat (limited to 'net-misc/nyx')
-rw-r--r--net-misc/nyx/Manifest1
-rw-r--r--net-misc/nyx/nyx-2.1.0-r5.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/nyx/Manifest b/net-misc/nyx/Manifest
index 14ed5c39e121..a6177765ae2f 100644
--- a/net-misc/nyx/Manifest
+++ b/net-misc/nyx/Manifest
@@ -1,3 +1,4 @@
DIST nyx-2.1.0.tar.gz 6908817 BLAKE2B e67305c0e2a066976cc828235bb364a238af2842251b466cc70bf8ad79138ffb5d6c598cf5900b777caf03ffefd0566e9eccfb65131ca0dc26670d71d8f9a756 SHA512 69a645cc811a1b1fbd9cf0501d8f23f1a52e0e92a0598097bb0c9efb040e1895e1dd431bad93be36db0e85ca7ac32ee5c866d50d2812069a39e5160b44575a37
EBUILD nyx-2.1.0-r4.ebuild 744 BLAKE2B 9aab456f1e450040266985263e62816e036f76b3220732b7caa8332fa09914f3d4af66244afd04f7a3bfcd5601008d70a4217bb7b9f3be83e7ec533a2606f43a SHA512 3112e7bbb99160ec38f7f9369a785938b796e9849794f56666b58e1f3ce8fa64fbaa35999f856ef1f915d2912d04bb8c09216e30ea81ffb6f09a15a34cb06ec5
+EBUILD nyx-2.1.0-r5.ebuild 886 BLAKE2B 15bc9095648467c0806bf7e3584fa6f820c1ac09301852389cfd321da6a93133d20e609ab7ec66e2ec8ecdad334a34750d5449b113fb20c516181cc0c7519876 SHA512 0f653af3011d46cae0f5b10d9da1a0f6a97ea073acf1cae10abc4dd24e44150bb585a277c57e50fddbdf5e89f6c0eba8f95a6274c5e0156489b4ce02aaff9fa2
MISC metadata.xml 239 BLAKE2B 1fb9280aa15020a1e294df309888ce1474f4adf5c9bed6e57f351fad2020e5a6869773a66acc7c26e5dd6ae3c064929b8c65576476a1e01e8ab05f40a43cd404 SHA512 efe6d1b33faf5158bbae729e022bd2da7c687f26bad4df9bed9a4238e5265e83f39b17d4de66cc7ac492100de8eb2cbd22dd118174c7aafb027c2107617185fd
diff --git a/net-misc/nyx/nyx-2.1.0-r5.ebuild b/net-misc/nyx/nyx-2.1.0-r5.ebuild
new file mode 100644
index 000000000000..105ebe53d874
--- /dev/null
+++ b/net-misc/nyx/nyx-2.1.0-r5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE='ncurses,sqlite(-)'
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Utility to monitor real time Tor status information"
+HOMEPAGE="https://nyx.torproject.org"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.torproject.org/nyx.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+# net-libs/stem-1.8.0_p20211118 was an incompatible git-snapshot
+# simply depend on net-libs/stem in the future
+RDEPEND="
+ || ( <net-libs/stem-1.8.0_p20211118[${PYTHON_USEDEP}] ~net-libs/stem-1.8.1[${PYTHON_USEDEP}] )
+ net-vpn/tor"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # bug #645336
+ doman nyx.1
+}