summaryrefslogtreecommitdiff
path: root/net-misc/nyx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
commit957235cf19a691360c720f7913672adda4258ed0 (patch)
tree812bba7928f4293ead05a7ee9c1ac39c5ef9f12e /net-misc/nyx
parent62f67115b5c46134c34f88f4b1cbdacc19384c0a (diff)
gentoo resync : 07.10.2018
Diffstat (limited to 'net-misc/nyx')
-rw-r--r--net-misc/nyx/Manifest3
-rw-r--r--net-misc/nyx/nyx-2.0.4.ebuild11
-rw-r--r--net-misc/nyx/nyx-9999.ebuild27
3 files changed, 37 insertions, 4 deletions
diff --git a/net-misc/nyx/Manifest b/net-misc/nyx/Manifest
index 91b743be3292..892259a58da2 100644
--- a/net-misc/nyx/Manifest
+++ b/net-misc/nyx/Manifest
@@ -1,3 +1,4 @@
DIST nyx-2.0.4.tar.gz 4074259 BLAKE2B 92296a319947803195a6ae3991f1991c9ee5dc8293144b31d143995a0b897e89812d4b012c330cb2d9e7ee2d2dbbc0ab0bbeb49135ec7e302aefde2dbe8159de SHA512 bb64b6c38bbfc9837215503a69b4a6b7a11b8a1e230f42c51a405472689a3d46d74dd06b2417c90512b63e9605b33198c5132b660f9eca037016a39c5e4f0ecf
-EBUILD nyx-2.0.4.ebuild 532 BLAKE2B 30ad1ebcaceb4e1868ef514849db3db8455a3d0b2810e5c97a9be409c3120af372122422fd4f283a526a2e5ddc07aa0d10c5854a1f2c0280cf1eccb00a7c00d3 SHA512 d1929d6236954df74741a5bd2398a1caded9134a708c9db8ebf3b3aa27df82b905ca6af8634094d0a7c3bafdb4414347f114788470df86680bb29767d2a68786
+EBUILD nyx-2.0.4.ebuild 638 BLAKE2B b1e8e29f6c828e0542f46ea48ed2bb43ccfb422555813af9f9d6074489e19f3f939d81a37bb3d4c79f297c7299414294d35d4cc1fd84d9ff6c5211d1ffb4137c SHA512 06f90b0cb50d4ff5c8be27002c21eea2919230c911b1aee10f69f2fe78a4db866967044a9e94f9289ffbae486a0698f8addd5d42bb2bea3382a159b0aafa9611
+EBUILD nyx-9999.ebuild 638 BLAKE2B b1e8e29f6c828e0542f46ea48ed2bb43ccfb422555813af9f9d6074489e19f3f939d81a37bb3d4c79f297c7299414294d35d4cc1fd84d9ff6c5211d1ffb4137c SHA512 06f90b0cb50d4ff5c8be27002c21eea2919230c911b1aee10f69f2fe78a4db866967044a9e94f9289ffbae486a0698f8addd5d42bb2bea3382a159b0aafa9611
MISC metadata.xml 328 BLAKE2B 388fd17862250e1c6df6dbcd5c29030fa6dd4ed70b8ba4e844fd9d1411f1f777bc5b448a7b52c177d5cb163e0e68976bbae55375da3c41c8e1a1719fd0fd96a0 SHA512 65455e32f59242a36f241e854624f0c38bcbe69cc70eafe39e8df6fbd6e000faf58d04a0310d018377d3440ad55a282f1bc8dbf83fa411221f13068675944737
diff --git a/net-misc/nyx/nyx-2.0.4.ebuild b/net-misc/nyx/nyx-2.0.4.ebuild
index 93d2f04eb224..a27cb04c7b15 100644
--- a/net-misc/nyx/nyx-2.0.4.ebuild
+++ b/net-misc/nyx/nyx-2.0.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -8,11 +8,16 @@ inherit vcs-snapshot distutils-r1
DESCRIPTION="Utility to monitor real time Tor status information"
HOMEPAGE="https://nyx.torproject.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.torproject.org/nyx.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+fi
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE="test"
DEPEND="
diff --git a/net-misc/nyx/nyx-9999.ebuild b/net-misc/nyx/nyx-9999.ebuild
new file mode 100644
index 000000000000..a27cb04c7b15
--- /dev/null
+++ b/net-misc/nyx/nyx-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+inherit vcs-snapshot distutils-r1
+
+DESCRIPTION="Utility to monitor real time Tor status information"
+HOMEPAGE="https://nyx.torproject.org"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.torproject.org/nyx.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ net-libs/stem
+ net-vpn/tor"