summaryrefslogtreecommitdiff
path: root/net-misc/ntpsec/ntpsec-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /net-misc/ntpsec/ntpsec-9999.ebuild
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'net-misc/ntpsec/ntpsec-9999.ebuild')
-rw-r--r--net-misc/ntpsec/ntpsec-9999.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/net-misc/ntpsec/ntpsec-9999.ebuild b/net-misc/ntpsec/ntpsec-9999.ebuild
index 050f701b387d..0d9f22dc3aa8 100644
--- a/net-misc/ntpsec/ntpsec-9999.ebuild
+++ b/net-misc/ntpsec/ntpsec-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PYTHON_COMPAT=( python2_7 python3_{5,6} )
PYTHON_REQ_USE='threads(+)'
-inherit flag-o-matic python-r1 waf-utils systemd user
+inherit flag-o-matic python-r1 waf-utils systemd
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -48,6 +48,8 @@ RDEPEND="${CDEPEND}
ntpviz? ( sci-visualization/gnuplot media-fonts/liberation-fonts )
!net-misc/ntp
!net-misc/openntpd
+ acct-group/ntp
+ acct-user/ntp
"
DEPEND="${CDEPEND}
app-text/asciidoc
@@ -60,11 +62,6 @@ DEPEND="${CDEPEND}
WAF_BINARY="${S}/waf"
-pkg_setup() {
- enewgroup ntp 123
- enewuser ntp 123 -1 /dev/null ntp
-}
-
src_prepare() {
default
# Remove autostripping of binaries
@@ -93,6 +90,7 @@ src_configure() {
--nopyc
--nopyo
--refclock="${CLOCKSTRING}"
+ --build-epoch="$(date +%s)"
$(use doc && echo "--enable-doc")
$(use early && echo "--enable-early-droproot")
$(use gdb && echo "--enable-debug-gdb")
@@ -122,6 +120,7 @@ src_install() {
waf-utils_src_install
}
python_foreach_impl run_in_build_dir python_install
+ python_foreach_impl python_optimize
# Install heat generating scripts
use heat && dosbin "${S}"/contrib/ntpheat{,usb}