summaryrefslogtreecommitdiff
path: root/net-misc/netopeer2/netopeer2-2.1.59-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-22 00:03:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-22 00:03:23 +0100
commitd3bd579653c6e5f8e1c0a36517372a262ade6c8d (patch)
tree7078b1e6375421ced0dbdd93a81dee1c6a3e04a3 /net-misc/netopeer2/netopeer2-2.1.59-r1.ebuild
parentebd51986f51b430f84c569c6c0f2fe051158d444 (diff)
gentoo auto-resync : 22:04:2023 - 00:03:23
Diffstat (limited to 'net-misc/netopeer2/netopeer2-2.1.59-r1.ebuild')
-rw-r--r--net-misc/netopeer2/netopeer2-2.1.59-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-misc/netopeer2/netopeer2-2.1.59-r1.ebuild b/net-misc/netopeer2/netopeer2-2.1.59-r1.ebuild
new file mode 100644
index 000000000000..242e6140a31b
--- /dev/null
+++ b/net-misc/netopeer2/netopeer2-2.1.59-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Server for implementing NETCONF configuration management"
+HOMEPAGE="https://github.com/CESNET/netopeer2"
+SRC_URI="https://github.com/CESNET/netopeer2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-misc/c_rehash
+ dev-libs/openssl:=
+ net-misc/curl:=
+ >=net-misc/sysrepo-2.2.60
+ >=net-libs/libnetconf2-2.1.31
+ net-libs/libssh:=
+ >=net-libs/libyang-2.1.55"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DGENERATE_HOSTKEY=OFF
+ -DINSTALL_MODULES=OFF
+ -DMERGE_LISTEN_CONFIG=OFF
+ -DENABLE_TESTS=OFF
+ -DENABLE_VALGRIND_TESTS=OFF
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ insinto /etc/netopeer2
+ doins -r scripts/.
+}
+
+pkg_postinst() {
+ elog "In order to do initial server setup please"
+ elog "run setup scripts located in /etc/netopeer2"
+}