summaryrefslogtreecommitdiff
path: root/net-misc/netopeer2/netopeer2-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /net-misc/netopeer2/netopeer2-2.0.0.ebuild
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'net-misc/netopeer2/netopeer2-2.0.0.ebuild')
-rw-r--r--net-misc/netopeer2/netopeer2-2.0.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-misc/netopeer2/netopeer2-2.0.0.ebuild b/net-misc/netopeer2/netopeer2-2.0.0.ebuild
new file mode 100644
index 000000000000..fa8bef0b722d
--- /dev/null
+++ b/net-misc/netopeer2/netopeer2-2.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Server for implementing NETCONF configuration management"
+HOMEPAGE="https://github.com/CESNET/netopeer2"
+SRC_URI="https://github.com/CESNET/netopeer2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/openssl:=
+ net-misc/curl:=
+ >=net-misc/sysrepo-2.0.0:=
+ >=net-libs/libnetconf2-2.0.0:=
+ net-libs/libssh:=
+ >=net-libs/libyang-2.0.0:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DGENERATE_HOSTKEY=OFF
+ -DINSTALL_MODULES=OFF
+ -DMERGE_LISTEN_CONFIG=OFF
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ insinto /etc/netopeer2
+ doins -r scripts/.
+}
+
+pkg_postinst() {
+ elog "In order to do initial server setup please"
+ elog "run setup scripts located in /etc/netopeer2"
+}