summaryrefslogtreecommitdiff
path: root/net-misc/netkit-timed
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-17 17:03:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-17 17:03:45 +0100
commitc9e9e39938097bf29063c271195ad0d7d7bd02a9 (patch)
treef2f4ab36d22272fec3a1d1313d8f700b1f0f6744 /net-misc/netkit-timed
parent0968caae52d6eae7513e2ce4e0900a2e009780ee (diff)
gentoo auto-resync : 17:09:2023 - 17:03:44
Diffstat (limited to 'net-misc/netkit-timed')
-rw-r--r--net-misc/netkit-timed/Manifest1
-rw-r--r--net-misc/netkit-timed/netkit-timed-0.17-r11.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/netkit-timed/Manifest b/net-misc/netkit-timed/Manifest
index ea8f670ac749..31b5f68c635d 100644
--- a/net-misc/netkit-timed/Manifest
+++ b/net-misc/netkit-timed/Manifest
@@ -3,4 +3,5 @@ AUX 0.17-timed-opt-parsing.patch 403 BLAKE2B e0164998a4845da439b640d60b3cdac1dd8
AUX timed.rc6 358 BLAKE2B 358a7b3fc14f30b0146e1269cf9327d9aaf64d8329b25c610b0405adfc91d4d21d6d14ec08c7234b53934460851db6f947117733b3d4070645503dbe1761eaa5 SHA512 cde2063563dd02b404560fa84bfa536f2f7c75e9271225e94b08630348d78639e386b8a0f59f04b389ad66f2d714c63edf2eed507b690d5ba989780b400547a4
DIST netkit-timed-0.17.tar.gz 48655 BLAKE2B 5e076394e2605569b8a9a34d47b59234ffa0f643a13ef7ac688b40d259079ec5d2eef99a0efa35d7975e11118c1fe87bd138edd98199dde68cc4d8d9f10c3599 SHA512 781a41555953a165949dde7e7279298d4faf348575ba1214c6ce60cdbc74f6f03ab31002d57a441cbcaf674f7e2cc00afa17632bc3fcb28e2afd95d39cd70b99
EBUILD netkit-timed-0.17-r10.ebuild 1019 BLAKE2B 000b7f43ea394aab89876c30d3f23bd3c63fa66010279c8dc6526653d8989c12089e3933ee4ea6637926cef2a3069674703cf345e64c3230d75a37b4bd3cf9b8 SHA512 c551b9a8d71a1b77ecfd72142924046e4d16882c274d129cda88fd06c26feba995afcc11ccb626e4e301cca3bba56fcc90a9c42fb011eebe1ab0b07a8c071635
+EBUILD netkit-timed-0.17-r11.ebuild 1061 BLAKE2B 211c3ad5aa6efc462161bf6fdc99f0f8c69908a8f88301cb0d004e68ede7fb23c4044bab0e5bc8bbbb7fcfb35ac0c8c8461bc7b1bc7d822cb5f629f8d15c0a1e SHA512 1968ad82aae9e35572912b30a3d9b69440bcde842b1590047a3f8dcb8f9d721f449a218f7ccdaab79f0e2a2e663be92f6e48e5bb098a337e24097a5ceb225d38
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/net-misc/netkit-timed/netkit-timed-0.17-r11.ebuild b/net-misc/netkit-timed/netkit-timed-0.17-r11.ebuild
new file mode 100644
index 000000000000..660a85f76e2a
--- /dev/null
+++ b/net-misc/netkit-timed/netkit-timed-0.17-r11.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Netkit - timed: Time daemon"
+HOMEPAGE="https://wiki.linuxfoundation.org/networking/netkit"
+SRC_URI="http://ftp.linux.org.uk/pub/linux/Networking/netkit/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+LICENSE="BSD GPL-2"
+SLOT="0"
+
+src_prepare() {
+ eapply "${FILESDIR}"/0.17-CFLAG-DEF-fix.patch
+ eapply "${FILESDIR}"/0.17-timed-opt-parsing.patch
+ sed -i -e '/^LDFLAGS=/d' configure || die "sed configure"
+ sed -i -e "s|ar -cruv|\${AR} -cruv|g" timed/lib/Makefile || die
+ default
+}
+
+src_configure() {
+ tc-export AR
+ # Note this is not an autoconf configure script. econf fails
+ append-flags -DCLK_TCK=CLOCKS_PER_SEC
+ ./configure --prefix=/usr --with-c-compiler="$(tc-getCC)" || die "bad configure"
+}
+
+src_install() {
+ dosbin timed/timed/timed
+ doman timed/timed/timed.8
+ dosbin timed/timedc/timedc
+ doman timed/timedc/timedc.8
+ einstalldocs
+
+ newinitd "${FILESDIR}"/timed.rc6 timed
+}