summaryrefslogtreecommitdiff
path: root/net-misc/netkit-rsh/netkit-rsh-0.17-r14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /net-misc/netkit-rsh/netkit-rsh-0.17-r14.ebuild
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'net-misc/netkit-rsh/netkit-rsh-0.17-r14.ebuild')
-rw-r--r--net-misc/netkit-rsh/netkit-rsh-0.17-r14.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/net-misc/netkit-rsh/netkit-rsh-0.17-r14.ebuild b/net-misc/netkit-rsh/netkit-rsh-0.17-r14.ebuild
new file mode 100644
index 000000000000..ade4c58496a1
--- /dev/null
+++ b/net-misc/netkit-rsh/netkit-rsh-0.17-r14.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit pam toolchain-funcs fcaps
+
+DESCRIPTION="Netkit's Remote Shell Suite: rexec{,d} rlogin{,d} rsh{,d}"
+HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${P}.tar.gz
+ mirror://gentoo/rexec-1.5.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="pam"
+
+RDEPEND="
+ sys-libs/ncurses:=
+ virtual/libcrypt:=
+ pam? ( >=sys-auth/pambase-20080219.1 )"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/xz-utils"
+
+PATCHES=(
+ "${FILESDIR}"/patches/
+)
+
+FILECAPS=( cap_net_bind_service usr/bin/r{cp,login,sh} )
+
+src_prepare() {
+ # This must happen before patches are applied
+ rm -r rexec || die
+ mv ../rexec rexec || die
+
+ default
+
+ if tc-is-cross-compiler ; then
+ # Can't do runtime tests when cross-compiling
+ sed -i -e "s|./__conftest|: ./__conftest|" configure || die
+ fi
+}
+
+src_configure() {
+ tc-export CC
+ ${CONFIG_SHELL:-/bin/sh} ./configure $(usex pam '' '--without-pam') || die
+
+ sed -i \
+ -e "s|-pipe -O2|${CFLAGS}|" \
+ -e "/^LDFLAGS=$/d" \
+ -e "s|-Wpointer-arith||" \
+ MCONFIG || die
+}
+
+src_install() {
+ insinto /etc/xinetd.d
+
+ local b
+ for b in rcp rexec{,d} rlogin{,d} rsh{,d} ; do
+ if [[ ${b} == *d ]] ; then
+ dosbin ${b}/${b}
+ dosym ${b} /usr/sbin/in.${b}
+ doman ${b}/${b}.8
+ else
+ dobin ${b}/${b}
+ doman ${b}/${b}.1
+ if [[ ${b} != rcp ]]; then
+ newins "${FILESDIR}"/${b}.xinetd ${b}
+
+ if use pam; then
+ newpamd "${FILESDIR}/${b}.pamd-pambase" ${b}
+ fi
+ fi
+ fi
+ done
+
+ dodoc README ChangeLog BUGS
+ newdoc rexec/README README.rexec
+}