summaryrefslogtreecommitdiff
path: root/net-misc/netevent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /net-misc/netevent
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'net-misc/netevent')
-rw-r--r--net-misc/netevent/Manifest3
-rw-r--r--net-misc/netevent/metadata.xml11
-rw-r--r--net-misc/netevent/netevent-2.0_p20200217.ebuild32
3 files changed, 46 insertions, 0 deletions
diff --git a/net-misc/netevent/Manifest b/net-misc/netevent/Manifest
new file mode 100644
index 000000000000..4852bdbc2ba0
--- /dev/null
+++ b/net-misc/netevent/Manifest
@@ -0,0 +1,3 @@
+DIST netevent-2.0_p20200217.tar.gz 39237 BLAKE2B 543456de89c6c57c7fe086d6697ca687ce0a04fce67efda7162e516eb1dca3f31b6ce31e1f5d7481fe538364f9f597103e3b77f3864c41456c6fe9080bfb424a SHA512 921982c8d9153e627c7931059e6163213ba2ac907f4ae98bcde62645e774cc41077ee728b698f3fad6a639fda19f99f9e43103006abe645f1a4ac4d68cf393c7
+EBUILD netevent-2.0_p20200217.ebuild 670 BLAKE2B ec4534fac8e8bf584485a90f7ba6d1c0af8a88700b961afabf41e1aecd16d921120415ced33bdc48788e5702f1d41a11797f5ec682470f159366dcb97e2cfb2e SHA512 6136d97214a2fb8d5b76d986624fc8768a63f83f770cde890a7fa1830b8d6626e48d42e6bb8f1e54bc3151e4825ce2fff02a8163dba675b31628d80dd19041d1
+MISC metadata.xml 325 BLAKE2B ea7c4382cb7e4e91b04a2b75f7af1924126d4a4592929dd19cc1f8d52b2cb81688c378f75dc12f08edaa12900c2577eec1fcb7f429e351e57bfe40ce525485b0 SHA512 22059c02dc58321f5d7d8dc7ea53ca486c4ff8949ace93f86da6d7d8d173988785590f3983bde637a4f6d511a28b301abb3c76254a113645314cf2f46843517d
diff --git a/net-misc/netevent/metadata.xml b/net-misc/netevent/metadata.xml
new file mode 100644
index 000000000000..bb16b0e7ff9b
--- /dev/null
+++ b/net-misc/netevent/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Blub/netevent</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/netevent/netevent-2.0_p20200217.ebuild b/net-misc/netevent/netevent-2.0_p20200217.ebuild
new file mode 100644
index 000000000000..f9936ce3b145
--- /dev/null
+++ b/net-misc/netevent/netevent-2.0_p20200217.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+COMMIT="c2066fa55db6f51090e00a240889d2f0cbd0ab4d"
+DESCRIPTION="Tool to share Linux event devices with other machines"
+HOMEPAGE="https://github.com/Blub/netevent"
+SRC_URI="https://github.com/Blub/netevent/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE="doc"
+
+BDEPEND="
+ doc? ( dev-python/docutils )
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_configure() {
+ tc-export CXX
+
+ # Not Autoconf.
+ RST2MAN=rst2man.py \
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ $(use_enable doc) \
+ || die
+}