summaryrefslogtreecommitdiff
path: root/net-misc/ndisc6/ndisc6-1.0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-16 20:31:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-16 20:31:05 +0100
commitae99f3df3fb5c7ebb085d4a198c1854a4c9a1bee (patch)
tree63845e7d405c04516103b1cee33911cea9a63b0e /net-misc/ndisc6/ndisc6-1.0.6.ebuild
parent2cb26483945211e812d7a0351ae472a676cd9592 (diff)
gentoo auto-resync : 16:08:2022 - 20:31:05
Diffstat (limited to 'net-misc/ndisc6/ndisc6-1.0.6.ebuild')
-rw-r--r--net-misc/ndisc6/ndisc6-1.0.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/ndisc6/ndisc6-1.0.6.ebuild b/net-misc/ndisc6/ndisc6-1.0.6.ebuild
new file mode 100644
index 000000000000..9118a255354e
--- /dev/null
+++ b/net-misc/ndisc6/ndisc6-1.0.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Recursive DNS Servers discovery Daemon (rdnssd) for IPv6"
+HOMEPAGE="https://www.remlab.net/ndisc6/"
+SRC_URI="https://www.remlab.net/files/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86 ~x64-macos"
+IUSE="debug"
+
+BDEPEND="dev-lang/perl
+ sys-devel/gettext"
+
+src_configure() {
+ econf $(use_enable debug assert)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newinitd "${FILESDIR}"/rdnssd.rc-1 rdnssd
+ newconfd "${FILESDIR}"/rdnssd.conf rdnssd
+
+ exeinto /etc/rdnssd
+ newexe "${FILESDIR}"/resolvconf-1 resolvconf
+ dodoc AUTHORS ChangeLog NEWS README
+
+ keepdir /var/lib/run/rdnssd
+}