summaryrefslogtreecommitdiff
path: root/net-misc/ndisc6/ndisc6-1.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/ndisc6/ndisc6-1.0.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/ndisc6/ndisc6-1.0.3.ebuild')
-rw-r--r--net-misc/ndisc6/ndisc6-1.0.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-misc/ndisc6/ndisc6-1.0.3.ebuild b/net-misc/ndisc6/ndisc6-1.0.3.ebuild
new file mode 100644
index 000000000000..1b789b871e42
--- /dev/null
+++ b/net-misc/ndisc6/ndisc6-1.0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Recursive DNS Servers discovery Daemon (rdnssd) for IPv6"
+HOMEPAGE="http://www.remlab.net/ndisc6/"
+SRC_URI="http://www.remlab.net/files/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug"
+
+DEPEND="dev-lang/perl
+ sys-devel/gettext"
+RDEPEND=""
+
+src_configure() {
+ econf $(use_enable debug assert)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ newinitd "${FILESDIR}"/rdnssd.rc-1 rdnssd || die
+ newconfd "${FILESDIR}"/rdnssd.conf rdnssd || die
+ exeinto /etc/rdnssd
+ newexe "${FILESDIR}"/resolvconf-1 resolvconf || die
+ dodoc AUTHORS ChangeLog NEWS README || die
+}