summaryrefslogtreecommitdiff
path: root/net-misc/mstpd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /net-misc/mstpd
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'net-misc/mstpd')
-rw-r--r--net-misc/mstpd/Manifest3
-rw-r--r--net-misc/mstpd/metadata.xml15
-rw-r--r--net-misc/mstpd/mstpd-0.0.9.ebuild32
3 files changed, 50 insertions, 0 deletions
diff --git a/net-misc/mstpd/Manifest b/net-misc/mstpd/Manifest
new file mode 100644
index 000000000000..3a26b0e0a314
--- /dev/null
+++ b/net-misc/mstpd/Manifest
@@ -0,0 +1,3 @@
+DIST mstpd-0.0.9.tar.gz 113711 BLAKE2B 93ff0213a634fcbbb613c79227d737c3961f4de669e0ac2c7351fa1c22842669edc652ba0deb24917a44df5a465a4e905a98e46ab7ccc7e4ebfd13039e6acfe0 SHA512 1d4a926d8437b7c41c69d2a047718181ca6245f3150e4aeb631f437edaaafe0c40b29802a6c9ea38c9f1dfb1b94149934b473f550358be10bb796295fa632e1e
+EBUILD mstpd-0.0.9.ebuild 724 BLAKE2B ac89c8db9a9ef8d325045414d5514acbd7640201d6eb937b19205271818eaa2468e55df99870d09ad24ffed78b1e8b9af5cf5d7a5d08b772198de5374b518c00 SHA512 abd8ac4c7cadb4203b4ec0894cb86bf4d96cad7534081f0a819104910b36f50495c8c656cc341095f64d20580ee7cc406f05a444433a9a5eac9c17144b400192
+MISC metadata.xml 444 BLAKE2B 6bbeee7e910599d9bbd586074b2b38f9a84b08d4b6a29961e4d0a9349a4d2a58d672125210eb7e3604a930983a86befe4ba855a75147fc4f507b8a98777785af SHA512 32ca1da084fde5cbcc37b8c474320f7d73db0a33f191c3f3e5d99b8cfd84bc71c6168238d402c0fd2ab00cb9b79faaa62e1ec6a88da75a3a2b2c499b999189c4
diff --git a/net-misc/mstpd/metadata.xml b/net-misc/mstpd/metadata.xml
new file mode 100644
index 000000000000..359cbebb4676
--- /dev/null
+++ b/net-misc/mstpd/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jakov.smolic@sartura.hr</email>
+ <name>Jakov Smolic</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mstpd/mstpd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/mstpd/mstpd-0.0.9.ebuild b/net-misc/mstpd/mstpd-0.0.9.ebuild
new file mode 100644
index 000000000000..32a39f6deb2b
--- /dev/null
+++ b/net-misc/mstpd/mstpd-0.0.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1 systemd
+
+DESCRIPTION="Multiple spanning tree protocol daemon"
+HOMEPAGE="https://github.com/mstpd/mstpd"
+SRC_URI="https://github.com/mstpd/mstpd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-bashcompletiondir="$(get_bashcompdir)" \
+ --with-systemdunitdir="$(systemd_get_systemunitdir)" \
+ --localstatedir="${EPREFIX}"/var
+}
+
+src_install() {
+ default
+ dosym ../../sbin/bridge-stp /lib/mstpctl-utils/mstpctl_restart_config
+ dosym bridge-stp /sbin/mstp_restart
+}