summaryrefslogtreecommitdiff
path: root/net-misc/mrouted/mrouted-4.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-05 09:36:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-05 09:36:29 +0100
commit77f1c17f5328e59f3991203c579fbc85df6898a0 (patch)
treea548ffa40d8592c0a65665c44087e6ec27d9280b /net-misc/mrouted/mrouted-4.5.ebuild
parent9ce4c0d3ec7daef46290a34cf0b02ae0d5b4f2f2 (diff)
gentoo auto-resync : 05:06:2023 - 09:36:29
Diffstat (limited to 'net-misc/mrouted/mrouted-4.5.ebuild')
-rw-r--r--net-misc/mrouted/mrouted-4.5.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-misc/mrouted/mrouted-4.5.ebuild b/net-misc/mrouted/mrouted-4.5.ebuild
new file mode 100644
index 000000000000..a51404357005
--- /dev/null
+++ b/net-misc/mrouted/mrouted-4.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs systemd
+
+DESCRIPTION="IP multicast routing daemon"
+HOMEPAGE="https://troglobit.com/projects/mrouted/"
+SRC_URI="https://github.com/troglobit/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="Stanford GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="rsrr test"
+
+# Needs unshare
+RESTRICT="!test? ( test ) test"
+
+BDEPEND="
+ app-alternatives/yacc
+ virtual/pkgconfig
+"
+
+src_configure() {
+ tc-export CC CXX
+
+ econf \
+ $(usev rsrr --enable-rsrr) \
+ $(use_enable test)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ default
+
+ insinto /etc
+ doins mrouted.conf
+
+ newinitd "${FILESDIR}"/mrouted.rc mrouted
+ systemd_dounit mrouted.service
+}