summaryrefslogtreecommitdiff
path: root/net-misc/mptcpd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /net-misc/mptcpd
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'net-misc/mptcpd')
-rw-r--r--net-misc/mptcpd/Manifest4
-rw-r--r--net-misc/mptcpd/metadata.xml11
-rw-r--r--net-misc/mptcpd/mptcpd-0.9.ebuild63
-rw-r--r--net-misc/mptcpd/mptcpd-9999.ebuild63
4 files changed, 141 insertions, 0 deletions
diff --git a/net-misc/mptcpd/Manifest b/net-misc/mptcpd/Manifest
new file mode 100644
index 000000000000..95dba01578c8
--- /dev/null
+++ b/net-misc/mptcpd/Manifest
@@ -0,0 +1,4 @@
+DIST mptcpd-0.9.tar.gz 654063 BLAKE2B fd9e8bf5cec517c934b9d38a736a128d087b54b5e4db90816a8cf8c242195fec8e3c4cd28d2f6e5a93326cac311a6b29048313c722004cea39e19448dc467976 SHA512 4fd292304d6270351b865e86cc401c1f5cc9043606b171e852bd37b2472c5f80061d760be68e5cd965caccb2f25c03d9ceea6232a5a587016c81f85e68ca8882
+EBUILD mptcpd-0.9.ebuild 1103 BLAKE2B 629897a77071480b8516bc646df0852838a88fe8122581ba13ff178691e3311dc9927d78502d7bb415fd506eb435887ff4b348f8a53d24b04966e9812eb381f8 SHA512 f9c005fbad040d994458e7c8cd9b64f929368de5f7d2ee7abc5f2d84deb944228d04966820c71bb01c42940001e8dc5e5110b268b9be8f9eefa9d33ed80403b0
+EBUILD mptcpd-9999.ebuild 1103 BLAKE2B 629897a77071480b8516bc646df0852838a88fe8122581ba13ff178691e3311dc9927d78502d7bb415fd506eb435887ff4b348f8a53d24b04966e9812eb381f8 SHA512 f9c005fbad040d994458e7c8cd9b64f929368de5f7d2ee7abc5f2d84deb944228d04966820c71bb01c42940001e8dc5e5110b268b9be8f9eefa9d33ed80403b0
+MISC metadata.xml 326 BLAKE2B 77d6f17ab473dfbdd5d156b8c6020ba80cf49d95fc9693c88b6f6a5f2a9449cc0caa53ba000183a4fba747d7e298b77528346c680049ea28fa86b9c308da0a34 SHA512 1150bc86b2b12c042e0de7eab7701808a703bd0a42e5a38eac94e07131f3138ee6c010644fd1837ef6240e1c83cf51553f8f99fd03970a2f84252aeee7e76f06
diff --git a/net-misc/mptcpd/metadata.xml b/net-misc/mptcpd/metadata.xml
new file mode 100644
index 000000000000..ed0b180f23fb
--- /dev/null
+++ b/net-misc/mptcpd/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">intel/mptcpd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/mptcpd/mptcpd-0.9.ebuild b/net-misc/mptcpd/mptcpd-0.9.ebuild
new file mode 100644
index 000000000000..8f307676ab46
--- /dev/null
+++ b/net-misc/mptcpd/mptcpd-0.9.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info systemd
+
+DESCRIPTION="Daemon that performs multipath TCP path management related operations."
+HOMEPAGE="https://github.com/intel/mptcpd/"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE="debug doc"
+
+RDEPEND="
+ >=dev-libs/ell-0.30.0
+ elibc_musl? ( sys-libs/argp-standalone )
+ "
+DEPEND="
+ ${RDEPEND}
+ >=sys-kernel/linux-headers-5.6
+ "
+BDEPEND="
+ doc? (
+ app-doc/doxygen
+ app-text/pandoc
+ )
+ virtual/pkgconfig
+ "
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/intel/mptcpd.git"
+else
+ SRC_URI="https://github.com/intel/mptcpd/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+CONFIG_CHECK="MPTCP"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999* ]] && eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-kernel=upstream
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ $(use_enable debug)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake
+ use doc && emake doxygen-doc
+}
+
+src_test() {
+ emake check
+}
diff --git a/net-misc/mptcpd/mptcpd-9999.ebuild b/net-misc/mptcpd/mptcpd-9999.ebuild
new file mode 100644
index 000000000000..8f307676ab46
--- /dev/null
+++ b/net-misc/mptcpd/mptcpd-9999.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info systemd
+
+DESCRIPTION="Daemon that performs multipath TCP path management related operations."
+HOMEPAGE="https://github.com/intel/mptcpd/"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE="debug doc"
+
+RDEPEND="
+ >=dev-libs/ell-0.30.0
+ elibc_musl? ( sys-libs/argp-standalone )
+ "
+DEPEND="
+ ${RDEPEND}
+ >=sys-kernel/linux-headers-5.6
+ "
+BDEPEND="
+ doc? (
+ app-doc/doxygen
+ app-text/pandoc
+ )
+ virtual/pkgconfig
+ "
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/intel/mptcpd.git"
+else
+ SRC_URI="https://github.com/intel/mptcpd/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+CONFIG_CHECK="MPTCP"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999* ]] && eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-kernel=upstream
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ $(use_enable debug)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake
+ use doc && emake doxygen-doc
+}
+
+src_test() {
+ emake check
+}