summaryrefslogtreecommitdiff
path: root/net-misc/monmotha
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/monmotha
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/monmotha')
-rw-r--r--net-misc/monmotha/Manifest6
-rw-r--r--net-misc/monmotha/files/monmotha.rc640
-rw-r--r--net-misc/monmotha/metadata.xml5
-rw-r--r--net-misc/monmotha/monmotha-2.3.8-r1.ebuild46
4 files changed, 97 insertions, 0 deletions
diff --git a/net-misc/monmotha/Manifest b/net-misc/monmotha/Manifest
new file mode 100644
index 000000000000..2cdce310481a
--- /dev/null
+++ b/net-misc/monmotha/Manifest
@@ -0,0 +1,6 @@
+AUX monmotha.rc6 825 SHA256 62f2fe153f57d35d153962b070e4bb38e208185a1fbc1085ad13193c3571fc58 SHA512 4d11a2c00d1829664a39ac1338b8dc803d4e32c8703a929b9ce93fdeed42e1ccdb11fa5ab7e837d883dae0a7534b1fe40cba281f4d88a3d291ebd2911e34bd10 WHIRLPOOL 938cda0eb27e1ef3248811007863aedd2653349400f2110bdc7b9198da0bfa3355c6710eb4278a22887c999940dd0b4c5220b94ddaa1dd0e59fd2b7a1c9f49c1
+DIST rc.firewall-2.3.8 56204 SHA256 4d273d377baebfa5404cbaf87a40227b0000133ecb56c0c7539f548f516929f0 SHA512 ccdd3427a274204c697a64a8936d4311cb34fbb66738c6afc4c242baad01407d1a36adac7a73b24b432943cd7cec05c9c1d9b2d4845b8b132bd61378c0c2e098 WHIRLPOOL 51527b521ac2ce7b4ce782afd7d98af30c6faf997598bf1d10bb31e6484a2b37f3e93ca9a3cf2401becff73387479f9b5b24812bec88d860b50c48671c292d3d
+EBUILD monmotha-2.3.8-r1.ebuild 1231 SHA256 d498bcd02a68e7cbd5cd15b35581d560e633f57fefb5d347c8135c5eb8a2def3 SHA512 a3ffd4a1adc3129e645d96c0ed82413f8944f5109577447587e8fb3a17e72f6714b1983d922913aed39f6e1a49e403cad032e1882bb10f0876f2dd8d550b020e WHIRLPOOL 865fd99c925c0fc0d027322be30036f162245255a739edd3910853b09ff4840e524a19995403525846c75086705f893157ccd2458eb8c3cfa7e4f63856ea9292
+MISC ChangeLog 2954 SHA256 23ab289f0d1cfa42b70f08b8caaeb9f77c69199554b3116c6a81b95d94976ba6 SHA512 167bee089cafda34e3d868ac42153956a287a7eaca2201b344b60b46b699943d5682b84a4e0d61ce5b5a807db2af21e6eb4d559a8964c3c917b63f336f0eb07e WHIRLPOOL 1ba04345d332d03948c470efc87e40888c070cb4d211430afa454bf4d778412612e8dd1e5e524ab1cb32a8ff4f6cfd982aeabd63e45b1b2d796d7d9ec188e39c
+MISC ChangeLog-2015 1570 SHA256 6a4f3a89b1aef247aebb36d7da2572f3b5f16f44704c750f1dc6905280983e15 SHA512 e044ccde95af7200f57f233035dadbeb7d27188d26a6aa87690ca0b28d64f976c8c2a834044dcbcdc4cb3073c0021270b30e674278f4f3c206fa57a8f7fb8f37 WHIRLPOOL 1aa580f8e56b7596e12baab377f5bfa103e8ef8f9cbc2da897d701690466a72e5a1a5028276155e67d974fd2576a67ac64e6907a96007515eba6d4f9a30fdaa9
+MISC metadata.xml 166 SHA256 2caff447f5bd2701d8456ada5cc633c41ef4373fa4bfeabeb73599d40bcc941b SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84 WHIRLPOOL 1ff70497eca6531f0e0614c72a19f4b8e5ff486a58d369f4f0b36308d1d6b01168f9da887740e3b9f536236be251d3fe05f904d27a9233a7cf613416ba882968
diff --git a/net-misc/monmotha/files/monmotha.rc6 b/net-misc/monmotha/files/monmotha.rc6
new file mode 100644
index 000000000000..9bd0eeb8e2b1
--- /dev/null
+++ b/net-misc/monmotha/files/monmotha.rc6
@@ -0,0 +1,40 @@
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting the MonMotha Firewall"
+ /etc/monmotha/monmotha > /var/log/monmotha.log
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping the MonMotha Firewall"
+
+ # RESET ALL IPTABLES STUFF
+
+ /sbin/iptables -P INPUT ACCEPT
+ /sbin/iptables -P FORWARD ACCEPT
+ /sbin/iptables -P OUTPUT ACCEPT
+
+ /sbin/iptables -t nat -P PREROUTING ACCEPT
+ /sbin/iptables -t nat -P POSTROUTING ACCEPT
+ /sbin/iptables -t nat -P OUTPUT ACCEPT
+
+ /sbin/iptables -t mangle -P PREROUTING ACCEPT
+ /sbin/iptables -t mangle -P OUTPUT ACCEPT
+
+ /sbin/iptables -F
+ /sbin/iptables -t nat -F
+ /sbin/iptables -t mangle -F
+
+ /sbin/iptables -X
+ /sbin/iptables -t nat -X
+ /sbin/iptables -t mangle -X
+
+ eend $?
+}
diff --git a/net-misc/monmotha/metadata.xml b/net-misc/monmotha/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/net-misc/monmotha/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>
diff --git a/net-misc/monmotha/monmotha-2.3.8-r1.ebuild b/net-misc/monmotha/monmotha-2.3.8-r1.ebuild
new file mode 100644
index 000000000000..99f20cae77ef
--- /dev/null
+++ b/net-misc/monmotha/monmotha-2.3.8-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="MonMotha IPTables-based firewall script"
+HOMEPAGE="http://monmotha.mplug.org/firewall/"
+LICENSE="GPL-2"
+
+KEYWORDS="x86 ~amd64"
+IUSE=""
+SLOT="0"
+RDEPEND=">=net-firewall/iptables-1.2.5"
+
+MY_PVP=(${PV//[-\._]/ })
+
+S=${WORKDIR}
+
+SRC_URI="http://monmotha.mplug.org/~monmotha/firewall/firewall/${MY_PVP[0]}.${MY_PVP[1]}/rc.firewall-${PV}"
+
+src_unpack() {
+ cp "${DISTDIR}"/${A} "${S}"/
+}
+
+src_install() {
+ newinitd "${FILESDIR}/monmotha.rc6" monmotha
+ exeinto /etc/monmotha
+ newexe "${S}/rc.firewall-${PV}" monmotha
+}
+
+pkg_postinst () {
+ einfo "Don't forget to add the 'monmotha' startup script to your default"
+ einfo "runlevel by typing the following command:"
+ einfo ""
+ einfo " rc-update add monmotha default"
+ einfo ""
+ einfo "You need to edit /etc/monmotha/monmotha before using"
+ einfo "it. Enter the right vars in the file, start the script"
+ einfo "by typing: '/etc/init.d/monmotha start' and it should work."
+ einfo ""
+ einfo "Don't forget to change the path to iptables!!!"
+ einfo ""
+ einfo "Note: If You are stopping the firewall, all iptables rulesets"
+ einfo "will be flushed!!!"
+ einfo ""
+}