summaryrefslogtreecommitdiff
path: root/net-misc/megatools/megatools-1.9.97.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/megatools/megatools-1.9.97.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/megatools/megatools-1.9.97.ebuild')
-rw-r--r--net-misc/megatools/megatools-1.9.97.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-misc/megatools/megatools-1.9.97.ebuild b/net-misc/megatools/megatools-1.9.97.ebuild
new file mode 100644
index 000000000000..42d283b633f9
--- /dev/null
+++ b/net-misc/megatools/megatools-1.9.97.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils
+
+DESCRIPTION="Command line tools and C library for accessing Mega cloud storage"
+HOMEPAGE="https://github.com/megous/megatools"
+SRC_URI="https://github.com/megous/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="fuse introspection static-libs"
+
+COMMON_DEPEND="dev-libs/glib:2
+ dev-libs/openssl:0
+ net-misc/curl
+ fuse? ( sys-fs/fuse )
+"
+RDEPEND="${COMMON_DEPEND}
+ net-libs/glib-networking[ssl]
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ app-text/asciidoc"
+
+src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ --enable-docs-build
+ --disable-maintainer-mode
+ --disable-warnings
+ --disable-glibtest
+ $(use_enable static-libs static)
+ $(use_enable introspection)
+ $(use_with fuse)
+ )
+ autotools-utils_src_configure
+}